aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-11-29 22:35:04 +0000
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-01-03 16:35:18 -0500
commit815821c139798e42e2c022a5c2128ea10e9d2fea (patch)
tree8329cd41c03743516a3f38a12890a4f4f3edcce0 /gnu/packages/golang.scm
parentd0dc31a56ec497e070eb6662c8ff6b4b3e5c7cef (diff)
downloadguix-815821c139798e42e2c022a5c2128ea10e9d2fea.tar
guix-815821c139798e42e2c022a5c2128ea10e9d2fea.tar.gz
gnu: go-github-com-google-safehtml: Move to (gnu packages golang-web).
* gnu/packages/golang.scm (go-github-com-google-safehtml): Move from here... * gnu/packages/golang-web.scm: ...to here. Change-Id: Ia1f14486f262d3695077c8e2f409f4928874c4f8
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm25
1 files changed, 0 insertions, 25 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 292d4f799d..84dead6293 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -12510,31 +12510,6 @@ production-ready implementation, compatible with the original Jsonnet C++
implementation.")
(license license:asl2.0)))
-(define-public go-github-com-google-safehtml
- (package
- (name "go-github-com-google-safehtml")
- (version "0.1.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/google/safehtml")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0j2xjy8xrk9y9k6bqpvimj84i6hg1wwsyvwsb0axhmp49cmnrp86"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/google/safehtml"))
- (propagated-inputs `(("go-golang-org-x-text" ,go-golang-org-x-text)))
- (home-page "https://github.com/google/safehtml")
- (synopsis "Safe HTML for Go")
- (description
- "Package safehtml provides immutable string-like types which represent values
-that are guaranteed to be safe, by construction or by escaping or sanitization,
-to use in various HTML contexts and with various DOM APIs.")
- (license license:bsd-3)))
-
(define-public go-github-com-google-shlex
(package
(name "go-github-com-google-shlex")