aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-13 00:12:33 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-15 12:17:52 +0100
commit717783f83d4de940b4dbf7a447d061188b947567 (patch)
treee2d9df4ff48bfefe2bf591ce35339926ec458c86 /gnu/packages/golang.scm
parent54f52ae1363ddc8c60051a678f941cc0c00b9877 (diff)
downloadguix-717783f83d4de940b4dbf7a447d061188b947567.tar
guix-717783f83d4de940b4dbf7a447d061188b947567.tar.gz
gnu: go-github-com-muesli-termenv: Update to 0.15.2.
* gnu/packages/golang.scm (go-github-com-muesli-termenv): Update to 0.15.2. [propagated-inputs]: Add go-github-com-aymanbagabas-go-osc52-v2, go-github-com-lucasb-eyer-go-colorful, go-github-com-mattn-go-isatty, go-github-com-mattn-go-runewidth, and go-golang-org-x-sys. [native-inputs]: Remove go-github-com-google-goterm, go-github-com-lucasb-eyer-go-colorful, go-github-com-mattn-go-isatty, and go-github-com-mattn-go-runewidth. Change-Id: I29fc31a2ef29921e2aaef4e20a32cd3738be20c6
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 2eee149ab6..60633fd0c0 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -6745,7 +6745,7 @@ helping you to transform blocks of text.")
(define-public go-github-com-muesli-termenv
(package
(name "go-github-com-muesli-termenv")
- (version "0.8.1")
+ (version "0.15.2")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -6754,15 +6754,16 @@ helping you to transform blocks of text.")
(file-name (git-file-name name version))
(sha256
(base32
- "0m24ljq1nq7z933fcvg99fw0fhxj9rb5ll4rlay7z2f2p59mrbdp"))))
+ "19yhli6k79aqpra4djp0cl4q76mqxbc1f7in20y0dzhnjb7yz42p"))))
(build-system go-build-system)
(arguments
`(#:import-path "github.com/muesli/termenv"))
- (native-inputs
- (list go-github-com-google-goterm
+ (propagated-inputs
+ (list go-github-com-aymanbagabas-go-osc52-v2
go-github-com-lucasb-eyer-go-colorful
go-github-com-mattn-go-isatty
- go-github-com-mattn-go-runewidth))
+ go-github-com-mattn-go-runewidth
+ go-golang-org-x-sys))
(home-page "https://github.com/muesli/termenv/")
(synopsis "Advanced styling options on the terminal")
(description "termenv lets you safely use advanced styling options on the