aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2019-07-13 17:40:31 -0400
committerLeo Famulari <leo@famulari.name>2019-07-13 17:41:21 -0400
commit4f61513128284fab8745a317b4663e36b042da5d (patch)
tree1aea5a3e9e00adcca6627ab35b357cf9e4202468 /gnu/packages/golang.scm
parent145fed2a2b499e840c22c0165b6c2d062dd2ce88 (diff)
downloadguix-4f61513128284fab8745a317b4663e36b042da5d.tar
guix-4f61513128284fab8745a317b4663e36b042da5d.tar.gz
gnu: Go: Use the default libgcc.
* gnu/packages/golang.scm (go-1.4)[inputs]: Replace gcc-6 with gcc.
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm6
1 files changed, 1 insertions, 5 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 2f5396dd1e..ba683905d6 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -195,11 +195,7 @@
(inputs
`(("tzdata" ,tzdata)
("pcre" ,pcre)
- ;; Building Go 1.10 with the Go 1.4 bootstrap, Thread Sanitizer from GCC
- ;; 5 finds a data race during the the test suite of Go 1.10. With GCC 6,
- ;; the race doesn't seem to be present:
- ;; https://github.com/golang/go/issues/24046
- ("gcc:lib" ,gcc-6 "lib")))
+ ("gcc:lib" ,gcc "lib")))
(native-inputs
`(("pkg-config" ,pkg-config)
("which" ,which)