aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-08-11 11:44:25 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-08-11 13:15:39 +0100
commit4412d0e160824eaa402ae21f990969e279b387d0 (patch)
tree365992fc1e86d55b400a896f65ef15a4fc57988a /gnu/packages/golang.scm
parentddeb0130549014c2b3f3c52766ae8bbd4f7265f0 (diff)
downloadguix-4412d0e160824eaa402ae21f990969e279b387d0.tar
guix-4412d0e160824eaa402ae21f990969e279b387d0.tar.gz
gnu: go-mvdan-cc-xurls: Move to golang-web.
* gnu/packages/golang.scm (go-mvdan-cc-xurls, xurls): Move from here... * gnu/packages/golang-web.scm: ... to here. * gnu/packages/messaging.scm: Add golang-web module. Change-Id: I990e5dff7d5813dc4b1c40e9a7707901235af458
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm43
1 files changed, 0 insertions, 43 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 2d7e2d1011..c4b32e8378 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -7492,49 +7492,6 @@ That is, @code{gofumpt} is happy with a subset of the formats that
(native-inputs '())
(inputs '())))
-(define-public go-mvdan-cc-xurls
- (package
- (name "go-mvdan-cc-xurls")
- (version "2.5.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/mvdan/xurls")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1516hwlxbnhdca56qy7sx9h2n5askq6ddqpqyp3f5rvmzdkxf4zn"))))
- (build-system go-build-system)
- (arguments
- `(#:import-path "mvdan.cc/xurls/v2"))
- (propagated-inputs
- (list go-github-com-rogpeppe-go-internal
- go-golang-org-x-mod
- go-golang-org-x-sync))
- (home-page "https://mvdan.cc/xurls/v2/")
- (synopsis "Extracts URLs from text")
- (description
- "Xurls extracts urls from plain text using regular expressions. It can
-be used as both a binary and a library.")
- (license license:bsd-3)))
-
-(define-public xurls
- (package
- (inherit go-mvdan-cc-xurls)
- (name "xurls")
- (arguments
- (list
- #:import-path "mvdan.cc/xurls/v2/cmd/xurls"
- #:unpack-path "mvdan.cc/xurls/v2"
- #:install-source? #f
- #:phases
- #~(modify-phases %standard-phases
- (add-after 'unpack 'disable-failing-tests
- (lambda* (#:key import-path #:allow-other-keys)
- (with-directory-excursion (string-append "src/" import-path)
- (delete-file "testdata/script/version.txtar")))))))))
-
(define-public go-github-com-davecgh-go-xdr
(package
(name "go-github-com-davecgh-go-xdr")