aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2023-11-05 09:17:10 +0300
committerLudovic Courtès <ludo@gnu.org>2023-11-25 23:35:02 +0100
commit3f8d50ecbdcf87d7f6cfeda5b1fddc3d506dd31c (patch)
tree1f9e0ebe787c899901838e4423e685495edbe2fc /gnu/packages/golang.scm
parentd51fb5ed3452235e12d8654e70dec0f121da0a90 (diff)
downloadguix-3f8d50ecbdcf87d7f6cfeda5b1fddc3d506dd31c.tar
guix-3f8d50ecbdcf87d7f6cfeda5b1fddc3d506dd31c.tar.gz
gnu: Add go-github-com-quic-go-qpack.
* gnu/packages/golang.scm (go-github-com-quic-go-qpack): New variable. Change-Id: I1ef8e677367a9a863897bfe884259782076e75fc Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 46d9b056d8..e8df68de18 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -7719,6 +7719,39 @@ Go 1.20.")
(home-page "https://github.com/quic-go/qtls-go1-20")
(license license:expat)))
+(define-public go-github-com-quic-go-qpack
+ (package
+ (name "go-github-com-quic-go-qpack")
+ (version "0.4.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/quic-go/qpack")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "00mjz445hhx4yar5l8p21bpp4d06jyg2ajw0ax7bh64d37l4kx39"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/quic-go/qpack"
+ ;; Tests require ginkgo v2.
+ #:tests? #f
+ #:go go-1.20))
+ (propagated-inputs (list go-github-com-onsi-gomega
+ go-github-com-onsi-ginkgo
+ go-golang-org-x-net))
+ (synopsis "Minimal QPACK (RFC 9204) implementation for Go")
+ (description
+ "A minimal QPACK (RFC 9204) implementation in Go. It is minimal in the sense
+that it doesn't use the dynamic table at all, but just the static table and (Huffman
+encoded) string literals. Wherever possible, it reuses code from the
+@url{https://github.com/golang/net/tree/master/http2/hpack, HPACK implementation in
+the Go standard library}.")
+ (home-page "https://github.com/quic-go/qpack")
+ (license license:expat)))
+
(define-public go-github-com-quic-go-quic-go
(package
(name "go-github-com-quic-go-quic-go")