aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2023-04-22 18:13:43 +0200
committerLeo Famulari <leo@famulari.name>2023-04-23 10:53:18 -0400
commit375ceda968f0d00000b87eb125188d5cbeddc1b6 (patch)
tree3d1e05dfd58357804ad51af08d1eb1b9ff150d8f /gnu/packages/golang.scm
parent0dd974d24b1ced2f5cd3d09ff54e10386e81ed70 (diff)
downloadguix-375ceda968f0d00000b87eb125188d5cbeddc1b6.tar
guix-375ceda968f0d00000b87eb125188d5cbeddc1b6.tar.gz
gnu: Add go-github-com-aws-smithy-go.
* gnu/packages/golang.scm (go-github-com-aws-smithy-go): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index bf17b7a300..e38146cbb9 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -11256,6 +11256,30 @@ encrypting JSON Web Tokens (JWT). It relies only on the standard library.")
(home-page "https://github.com/dvsekhvalnov/jose2go")
(license license:expat)))
+(define-public go-github-com-aws-smithy-go
+ (package
+ (name "go-github-com-aws-smithy-go")
+ (version "1.13.5")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/aws/smithy-go")
+ (commit "v1.13.5")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1rgyk0m2d3agknnlzjqvac1a61wwdq1pbck7vyl587m38n5zi2cz"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/aws/smithy-go"))
+ (propagated-inputs
+ (list go-github-com-jmespath-go-jmespath go-github-com-google-go-cmp-cmp))
+ (home-page "https://github.com/aws/smithy-go")
+ (synopsis "Smithy code generators for Go")
+ (description
+ "Package smithy provides the core components for a Smithy SDK.")
+ (license license:asl2.0)))
+
(define-public aws-vault
(package
(name "aws-vault")