aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-13 23:11:44 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-15 12:17:53 +0100
commit1b650288e5646b185eac986f2b6c20c0d8cbbdb1 (patch)
tree8fa0a1a02669cad33c6b27557f5a7c4ef110cd74 /gnu/packages/golang.scm
parent8b1d7742725aef814118198d26ab097295021189 (diff)
downloadguix-1b650288e5646b185eac986f2b6c20c0d8cbbdb1.tar
guix-1b650288e5646b185eac986f2b6c20c0d8cbbdb1.tar.gz
gnu: gopls: Adjust package style
* gnu/packages/golang.scm (gopls): Apply new package style, adjust indentation and swap propagated-inputs to native-inputs. [propagated-inputs]: Remove go-github-com-google-go-cmp-cmp, go-github-com-jba-printsrc, go-github-com-jba-templatecheck, go-github-com-sergi-go-diff, go-golang-org-x-mod, go-golang-org-x-sync, go-golang-org-x-sys, go-golang-org-x-text, go-golang-org-x-tools, go-golang-org-x-vuln, go-gopkg-in-yaml-v3, go-honnef-co-go-tools, go-mvdan-cc-gofumpt, and go-mvdan-cc-xurls. [native-inputs]: Add go-github-com-google-go-cmp-cmp, go-github-com-jba-printsrc, go-github-com-jba-templatecheck, go-github-com-sergi-go-diff, go-golang-org-x-mod, go-golang-org-x-sync, go-golang-org-x-sys, go-golang-org-x-text, go-golang-org-x-tools, go-golang-org-x-vuln, go-gopkg-in-yaml-v3, go-honnef-co-go-tools, go-mvdan-cc-gofumpt, and go-mvdan-cc-xurls. Change-Id: I1139e19731ea8002835bd14c8592f22ccc79ded3
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm63
1 files changed, 33 insertions, 30 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index beafe30e6d..f81c30b07a 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3219,38 +3219,41 @@ the @url{https://vuln.go.dev,Go Vulnerability Database}.")
;; XXX: Starting from 0.14.0 gppls needs golang.org/x/telemetry, which
;; needs to be discussed if it may be included in Guix.
(version "0.13.2")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://go.googlesource.com/tools")
- (commit (string-append "gopls/v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1qym2c0xvv6vcgwh0kz8sw094r88lzrl08xpvmg08lrqi00ma6kx"))))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://go.googlesource.com/tools")
+ (commit (string-append "gopls/v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1qym2c0xvv6vcgwh0kz8sw094r88lzrl08xpvmg08lrqi00ma6kx"))))
(build-system go-build-system)
(arguments
- `(#:import-path "golang.org/x/tools/gopls"
- #:unpack-path "golang.org/x/tools"
- #:install-source? #f
- #:phases (modify-phases %standard-phases
- (add-before 'unpack 'override-tools
- (lambda _
- (delete-file-recursively "src/golang.org/x/tools"))))))
- (propagated-inputs (list go-github-com-google-go-cmp-cmp
- go-github-com-jba-printsrc
- go-github-com-jba-templatecheck
- go-github-com-sergi-go-diff
- go-golang-org-x-mod
- go-golang-org-x-sync
- go-golang-org-x-sys
- go-golang-org-x-text
- go-golang-org-x-tools
- go-golang-org-x-vuln
- go-gopkg-in-yaml-v3
- go-honnef-co-go-tools
- go-mvdan-cc-gofumpt
- go-mvdan-cc-xurls))
+ (list
+ #:install-source? #f
+ #:import-path "golang.org/x/tools/gopls"
+ #:unpack-path "golang.org/x/tools"
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'unpack 'override-tools
+ (lambda _
+ (delete-file-recursively "src/golang.org/x/tools"))))))
+ (native-inputs
+ (list go-github-com-google-go-cmp-cmp
+ go-github-com-jba-printsrc
+ go-github-com-jba-templatecheck
+ go-github-com-sergi-go-diff
+ go-golang-org-x-mod
+ go-golang-org-x-sync
+ go-golang-org-x-sys
+ go-golang-org-x-text
+ go-golang-org-x-tools
+ go-golang-org-x-vuln
+ go-gopkg-in-yaml-v3
+ go-honnef-co-go-tools
+ go-mvdan-cc-gofumpt
+ go-mvdan-cc-xurls))
(home-page "https://golang.org/x/tools/gopls")
(synopsis "Official language server for the Go language")
(description