aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang-web.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-08-21 14:03:55 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-08-21 14:04:11 +0100
commit1c69f719affc6957e4c69960fa49d359d1b5e659 (patch)
tree0c61e1e1e3810ec06f5d0c9a9888ce2d21704629 /gnu/packages/golang-web.scm
parent5812c99b85e31dfe3ecdcc07decb796b4df34290 (diff)
downloadguix-1c69f719affc6957e4c69960fa49d359d1b5e659.tar
guix-1c69f719affc6957e4c69960fa49d359d1b5e659.tar.gz
gnu: Add go-github-com-evanphx-json-patch.
* gnu/packages/golang-web.scm (go-github-com-evanphx-json-patch): New variable. Change-Id: Ie06fd752cd61a9f2dfef7c7ca563fe17b62777d6
Diffstat (limited to 'gnu/packages/golang-web.scm')
-rw-r--r--gnu/packages/golang-web.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index f436d0ce7c..c9d755f606 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -1009,6 +1009,34 @@ developers to use @code{http} methods explicitly and in a way that's
consistent with the HTTP protocol definition.")
(license license:expat)))
+(define-public go-github-com-evanphx-json-patch
+ (package
+ (name "go-github-com-evanphx-json-patch")
+ (version "0.5.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/evanphx/json-patch")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "00sib9ba8j1h1n3r1cxx48zn8hs6sxwnrh78p6wbs28wcpz8nqxi"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/evanphx/json-patch"))
+ (propagated-inputs
+ (list go-github-com-jessevdk-go-flags go-github-com-pkg-errors))
+ (home-page "https://github.com/evanphx/json-patch")
+ (synopsis "Apply and create JSON (RFC6902 and RFC7386) patches for Golang")
+ (description
+ "@code{jsonpatch} is a library which provides functionality for both
+applying @url{http://tools.ietf.org/html/rfc6902,RFC6902 JSON patches} against
+documents, as well as for calculating & applying
+@url{https://tools.ietf.org/html/rfc7396,RFC7396 JSON merge patches}.")
+ (license license:bsd-3)))
+
(define-public go-github-com-felixge-httpsnoop
(package
(name "go-github-com-felixge-httpsnoop")