aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang-crypto.scm
diff options
context:
space:
mode:
authorBenjamin <benjamin@uvy.fr>2023-11-18 19:17:28 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-08 21:46:22 +0000
commitff61ca41d903d75cb01fb31b860c9660bbd836cc (patch)
tree906b0297ef20122630b6d4461e76de1f809022c3 /gnu/packages/golang-crypto.scm
parent8798f940ad0492da140ff170b18799029306c7a8 (diff)
downloadguix-ff61ca41d903d75cb01fb31b860c9660bbd836cc.tar
guix-ff61ca41d903d75cb01fb31b860c9660bbd836cc.tar.gz
gnu: Add go-github-com-minio-highwayhash.
* gnu/packages/golang-crypto.scm (go-github-com-minio-highwayhash): New variable. Change-Id: Ib6aa8a38946841e840b17848b07434487f0435ef Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu/packages/golang-crypto.scm')
-rw-r--r--gnu/packages/golang-crypto.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/golang-crypto.scm b/gnu/packages/golang-crypto.scm
index c8aa7fec0a..eb232611bb 100644
--- a/gnu/packages/golang-crypto.scm
+++ b/gnu/packages/golang-crypto.scm
@@ -15,6 +15,7 @@
;;; Copyright © 2022 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2022, 2023 Nicolas Graves <ngraves@ngraves.fr>
;;; Copyright © 2023 Artyom V. Poptsov <poptsov.artyom@gmail.com>
+;;; Copyright © 2023 Benjamin <benjamin@uvy.fr>
;;; Copyright © 2023 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2023 Felix Lechner <felix.lechner@lease-up.com>
;;; Copyright © 2023 Jack Hill <jackhill@jackhill.us>
@@ -611,6 +612,31 @@ performance is obtained with AVX2 which gives roughly a 4X performance
increase approaching hashing speeds of 1GB/sec on a single core.")
(license license:asl2.0))))
+(define-public go-github-com-minio-highwayhash
+ (package
+ (name "go-github-com-minio-highwayhash")
+ (version "1.0.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/minio/highwayhash")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1inrix7720273ccynxcyi7xsgc55cskxrw7gwn08qkmdj9xdxqai"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/minio/highwayhash"))
+ (propagated-inputs (list go-golang-org-x-sys))
+ (home-page "https://github.com/minio/highwayhash")
+ (synopsis "HighwayHash library for Go")
+ (description
+ "This package implements the pseudo-random-function (PRF) HighwayHash.
+HighwayHash is a fast hash function designed to defend hash-flooding attacks
+or to authenticate short-lived messages.")
+ (license license:asl2.0)))
+
(define-public go-github-com-minio-sha256-simd
(package
(name "go-github-com-minio-sha256-simd")