aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang-crypto.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-01-17 00:23:30 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-01-28 23:21:05 +0000
commitbf30f46716d70d1e143a0a2a2c96ad2f212a3c19 (patch)
treeb07c15e4840e4bb08e1ef3110c7fef9c917b4504 /gnu/packages/golang-crypto.scm
parent9ae4da0018557c690d6a177ab7cfda5feaaa1e75 (diff)
downloadguix-bf30f46716d70d1e143a0a2a2c96ad2f212a3c19.tar
guix-bf30f46716d70d1e143a0a2a2c96ad2f212a3c19.tar.gz
gnu: go-github-com-minio-blake2b-simd: Move to (gnu packages golang-crypto).
* gnu/packages/golang.scm (go-github-com-minio-blake2b-simd): Move from here ... * gnu/packages/golang-crypto.scm: ... to here. Change-Id: I096cf86c48b0fdcbf7c5d0b454d45de12018c908
Diffstat (limited to 'gnu/packages/golang-crypto.scm')
-rw-r--r--gnu/packages/golang-crypto.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/golang-crypto.scm b/gnu/packages/golang-crypto.scm
index 2b2e9d877f..00a6f51313 100644
--- a/gnu/packages/golang-crypto.scm
+++ b/gnu/packages/golang-crypto.scm
@@ -432,6 +432,37 @@ library's internal ChaCha20 package.")
the Go standard library's TLS 1.3 implementation.")
(license license:bsd-3)))
+(define-public go-github-com-minio-blake2b-simd
+ (let ((commit "3f5f724cb5b182a5c278d6d3d55b40e7f8c2efb4")
+ (revision "0"))
+ (package
+ (name "go-github-com-minio-blake2b-simd")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/minio/blake2b-simd")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0b6jbnj62c0gmmfd4zdmh8xbg01p80f13yygir9xprqkzk6fikmd"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/minio/blake2b-simd"))
+ (home-page "https://github.com/minio/blake2b-simd")
+ (synopsis "Fast hashing in pure Go of BLAKE2b with SIMD instructions")
+ (description "This package was initially based on the pure go BLAKE2b
+implementation of Dmitry Chestnykh and merged with the (cgo dependent) AVX
+optimized BLAKE2 implementation (which in turn is based on the official
+implementation. It does so by using Go's Assembler for amd64 architectures
+with a golang only fallback for other architectures.
+
+In addition to AVX there is also support for AVX2 as well as SSE. Best
+performance is obtained with AVX2 which gives roughly a 4X performance
+increase approaching hashing speeds of 1GB/sec on a single core.")
+ (license license:asl2.0))))
+
(define-public go-github-com-minio-sha256-simd
(package
(name "go-github-com-minio-sha256-simd")