aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang-crypto.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-01-16 23:58:02 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-01-28 23:21:05 +0000
commit06e70201f3a5a54399fe6de29e6160816d5e4195 (patch)
tree4783c427d5eedfa71d17ed24d3d24c906d3f8623 /gnu/packages/golang-crypto.scm
parent857be8fb4713a399120e3357ccb02a89989a7675 (diff)
downloadguix-06e70201f3a5a54399fe6de29e6160816d5e4195.tar
guix-06e70201f3a5a54399fe6de29e6160816d5e4195.tar.gz
gnu: go-github-com-cloudflare-circl: Move to (gnu packages golang-crypto).
* gnu/packages/golang.scm (go-github-com-cloudflare-circl): Move from here ... * gnu/packages/golang-crypto.scm: ... to here. Change-Id: I6d01b67c795d32387e0b77f1ea53d3a4a8f9939b
Diffstat (limited to 'gnu/packages/golang-crypto.scm')
-rw-r--r--gnu/packages/golang-crypto.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/golang-crypto.scm b/gnu/packages/golang-crypto.scm
index bfeea103ca..23c47712a5 100644
--- a/gnu/packages/golang-crypto.scm
+++ b/gnu/packages/golang-crypto.scm
@@ -163,6 +163,35 @@ been designed so it can be used as a standalone package for any projects
needing to use secp256k1 elliptic curve cryptography.")
(license license:isc))))
+(define-public go-github-com-cloudflare-circl
+ (package
+ (name "go-github-com-cloudflare-circl")
+ (version "1.3.6")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/cloudflare/circl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "05hk5svprcjrj6k4mg4kd732pnb658llqv04z6xrcl5v77jda2kd"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/cloudflare/circl"))
+ (propagated-inputs
+ (list go-github-com-bwesterb-go-ristretto
+ go-golang-org-x-crypto
+ go-golang-org-x-sys))
+ (home-page "https://blog.cloudflare.com/introducing-circl")
+ (synopsis "Cloudflare Interoperable Reusable Cryptographic Library")
+ (description "CIRCL (Cloudflare Interoperable, Reusable Cryptographic
+Library) is a collection of cryptographic primitives written in Go. The goal
+of this library is to be used as a tool for experimental deployment of
+cryptographic algorithms targeting Post-Quantum (PQ) and Elliptic Curve
+Cryptography (ECC).")
+ (license license:bsd-3)))
+
(define-public go-github-com-emersion-go-pgpmail
(package
(name "go-github-com-emersion-go-pgpmail")