aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang-check.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-03-16 22:57:44 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-03-16 22:58:05 +0000
commitd2824346bc047562a67272e394f1fb1ab1f6b2be (patch)
treea04a4985a3eb920e219ae141f97c4fa9f62e525b /gnu/packages/golang-check.scm
parent4fe9aae225fa4ee0416d7cfa984bda8fcded8436 (diff)
downloadguix-d2824346bc047562a67272e394f1fb1ab1f6b2be.tar
guix-d2824346bc047562a67272e394f1fb1ab1f6b2be.tar.gz
gnu: Add go-github-com-jbenet-go-cienv.
* gnu/packages/golang-check.scm (go-github-com-jbenet-go-cienv): New variable. Change-Id: I3a24335bff63f4364695cad6a1c88ea09dc8d357
Diffstat (limited to 'gnu/packages/golang-check.scm')
-rw-r--r--gnu/packages/golang-check.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index aaa2de33a6..290afdd3b9 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -404,6 +404,31 @@ signalling failures, it offers ways to express expectations and get nice failure
messages automatically.")
(license license:asl2.0))))
+(define-public go-github-com-jbenet-go-cienv
+ (package
+ (name "go-github-com-jbenet-go-cienv")
+ (version "0.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jbenet/go-cienv")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1qyfjvr8n5chpb5zi6r9cf0danrwds3k5lbf7vp7ygcl6wnm0vmv"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/jbenet/go-cienv"))
+ (home-page "https://github.com/jbenet/go-cienv")
+ (synopsis "CI system environment variables")
+ (description
+ "Package @code{cienv} implements some helper functions to use during tests.
+Many times certain facilities are not available, or tests must run
+differently.")
+ (license license:expat)))
+
(define-public go-github-com-onsi-ginkgo
(package
(name "go-github-com-onsi-ginkgo")