aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang-check.scm
diff options
context:
space:
mode:
authorFries <fries1234@protonmail.com>2023-08-05 11:01:47 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-04-06 13:14:42 +0100
commitc973dc2d64212d814eabce734a5694f896e78f76 (patch)
tree6a6f3473eaf6a89ab8f495ea7fd8074af9bf1e5a /gnu/packages/golang-check.scm
parent91709fa44255f3281eca787b573dde9777eacd1d (diff)
downloadguix-c973dc2d64212d814eabce734a5694f896e78f76.tar
guix-c973dc2d64212d814eabce734a5694f896e78f76.tar.gz
gnu: Add go-github-com-felixge-fgprof.
* gnu/packages/golang-check.scm (go-github-com-felixge-fgprof): New variable. Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com> Change-Id: Ib97bfc180e1bfffbc01aee348feb15431650ddb5
Diffstat (limited to 'gnu/packages/golang-check.scm')
-rw-r--r--gnu/packages/golang-check.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index 596cb1c7b2..1f76068c3e 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -191,6 +191,42 @@ style).
@end itemize")
(license license:isc)))
+(define-public go-github-com-felixge-fgprof
+ (package
+ (name "go-github-com-felixge-fgprof")
+ (version "0.9.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/felixge/fgprof")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "00h4kphvmbcdgad0wmqbaclc4a1pipdb55ay41mwh6cnkdjjvhp0"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/felixge/fgprof"))
+ (native-inputs
+ (list go-github-com-stretchr-testify))
+ (propagated-inputs
+ (list go-github-com-google-pprof))
+ (home-page "https://github.com/felixge/fgprof")
+ (synopsis "Sampling profiler for Golang")
+ (description
+ "@code{fgprof} is a sampling Go profiler providing analyze On-CPU as well
+as @url{http://www.brendangregg.com/offcpuanalysis.html, Off-CPU} (e.g. I/O)
+time together.
+
+Go's builtin sampling CPU profiler can only show On-CPU time, but it's better
+than fgprof at that. Go also includes tracing profilers that can analyze I/O,
+but they can't be combined with the CPU profiler.
+
+fgprof is designed for analyzing applications with mixed I/O and CPU
+workloads. This kind of profiling is also known as wall-clock profiling.")
+ (license license:expat)))
+
(define-public go-github-com-frankban-quicktest
(package
(name "go-github-com-frankban-quicktest")