aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang-check.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-02-13 21:12:53 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-13 21:26:40 +0000
commitac470c516e19f194228edf9e348bdbc7fc10f97a (patch)
tree627f455e25250dcab907ff0b7299b7e780975551 /gnu/packages/golang-check.scm
parentd024f3ffba611bf57302f02eb408cacee237f5bc (diff)
downloadguix-ac470c516e19f194228edf9e348bdbc7fc10f97a.tar
guix-ac470c516e19f194228edf9e348bdbc7fc10f97a.tar.gz
gnu: go-github-com-go-test-deep: Move to golang-check.
* gnu/packages/golang.scm (go-github-com-go-test-deep): Move from here ... * gnu/packages/golang-check.scm: ... to here. Change-Id: I47fec9c4e399067494eb20c214a47958b3cf755d
Diffstat (limited to 'gnu/packages/golang-check.scm')
-rw-r--r--gnu/packages/golang-check.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index f6ba0682b0..ad84ea2760 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -190,6 +190,30 @@ style).
tests.")
(license license:expat)))
+(define-public go-github-com-go-test-deep
+ (package
+ (name "go-github-com-go-test-deep")
+ (version "1.0.8")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/go-test/deep")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1mmw2w3by7y24jjpjwmf2gfl08c65jihn3si9m0sswmagmdsk8q0"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:import-path "github.com/go-test/deep"))
+ (home-page "https://github.com/go-test/deep")
+ (synopsis "Human-friendly deep variable equality in Go")
+ (description
+ "The deep package provides the deep.Equal function which is like
+reflect.DeepEqual but returns a list of differences. This is helpful
+when comparing complex types like structures and maps.")
+ (license license:expat)))
+
(define-public go-github-com-golangplus-testing
(package
(name "go-github-com-golangplus-testing")