aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang-check.scm
diff options
context:
space:
mode:
authorHilton Chain <hako@ultrarare.space>2023-07-29 01:19:48 +0800
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-16 14:17:32 +0000
commit5a09b0447bd4fb1661314263415818cc0bae1053 (patch)
tree234a79ba5aa27d0c6476c9cbe88be3869bed4950 /gnu/packages/golang-check.scm
parent8595b82d5536f4b18ce9a78142ee02fd7dd8fd4a (diff)
downloadguix-5a09b0447bd4fb1661314263415818cc0bae1053.tar
guix-5a09b0447bd4fb1661314263415818cc0bae1053.tar.gz
gnu: Add go-github-com-hexops-gotextdiff.
* gnu/packages/golang-check.scm (go-github-com-hexops-gotextdiff): New variable. Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com> Change-Id: Id133f1970759e104213726d4243600f86097aaad
Diffstat (limited to 'gnu/packages/golang-check.scm')
-rw-r--r--gnu/packages/golang-check.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index ad84ea2760..93392a82b4 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -292,6 +292,28 @@ also update a file with new \"golden\" output that is deemed correct.")
values for the purpose of fuzz testing.")
(license license:asl2.0))))
+(define-public go-github-com-hexops-gotextdiff
+ (package
+ (name "go-github-com-hexops-gotextdiff")
+ (version "1.0.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hexops/gotextdiff")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1vgq6w0cfhr76qlczgm5khsj1wnjkva0vhkh3qspaa1nkfw3jny1"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:import-path "github.com/hexops/gotextdiff"))
+ (home-page "https://github.com/hexops/gotextdiff")
+ (synopsis "Unified text diffing in Go")
+ (description
+ "This package provides a library to generate unified diffs.")
+ (license license:bsd-3)))
+
(define-public go-github-com-jacobsa-oglematchers
(let ((commit "141901ea67cd4769c6800aa7bfdfc558fa22bda5")
(revision "0"))