aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang-check.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-03-31 12:00:44 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-04-04 17:16:56 +0100
commit569397e22fda036a49212808c5ae1693dca30be6 (patch)
tree2e7666bf7cd59de65e13263a2835610a14cbda16 /gnu/packages/golang-check.scm
parentfdcd3a107a18c7dee17bc87b2cc35cacfb2e45ff (diff)
downloadguix-569397e22fda036a49212808c5ae1693dca30be6.tar
guix-569397e22fda036a49212808c5ae1693dca30be6.tar.gz
gnu: Add go-github-com-onsi-ginkgo-v2.
* gnu/packages/golang-check.scm (go-github-com-onsi-ginkgo-v2): New variable. Change-Id: Ied8167b850d5e5262713d0858ef7160d5c3d74c2
Diffstat (limited to 'gnu/packages/golang-check.scm')
-rw-r--r--gnu/packages/golang-check.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index 1558536182..6f36615ab0 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -460,6 +460,33 @@ builds on top of Go's builtin @code{testing} library and is complemented by the
Gomega matcher library.")
(license license:expat)))
+(define-public go-github-com-onsi-ginkgo-v2
+ (package
+ (inherit go-github-com-onsi-ginkgo)
+ (name "go-github-com-onsi-ginkgo-v2")
+ (version "2.17.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/onsi/ginkgo")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "089x6pz5563ldbxiwaqvd2g4dqfzlr25dflmas3gfq51ibwzh4vz"))))
+ (arguments
+ (list
+ #:go go-1.20
+ #:import-path "github.com/onsi/ginkgo/v2"))
+ (propagated-inputs
+ (list go-github-com-go-logr-logr
+ ;; go-github-com-google-pprof ; not packed yet in Guix, for profiling
+ go-github-com-onsi-gomega
+ go-github-com-go-task-slim-sprig
+ go-golang-org-x-net
+ go-golang-org-x-sys
+ go-golang-org-x-tools))))
+
(define-public go-github-com-prashantv-gostub
(package
(name "go-github-com-prashantv-gostub")