aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang-check.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-10-19 02:29:11 +0100
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-10-22 22:17:30 -0400
commit0a881fdaa7ea93b0f55ce78be75547fa2575085a (patch)
treeee4a799265f7b7e2c4adcf64ba1e172302e6a1dd /gnu/packages/golang-check.scm
parentf6a03a8ba69ead8ab3bc39f9f750ac6d036c6b0b (diff)
downloadguix-0a881fdaa7ea93b0f55ce78be75547fa2575085a.tar
guix-0a881fdaa7ea93b0f55ce78be75547fa2575085a.tar.gz
gnu: go-golang-org-sql-mock: Move to (gnu packages golang-check).
* gnu/packages/golang-check.scm (go-golang-org-sql-mock): Move from here... * gnu/packages/golang.scm: ... to here. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu/packages/golang-check.scm')
-rw-r--r--gnu/packages/golang-check.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index 56f412224e..8fc9d2fbc0 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2018 Pierre-Antoine Rouby <pierre-antoine.rouby@inria.fr>
+;;; Copyright © 2019 Brian Leung <bkleung89@gmail.com>
;;; Copyright © 2019 Leo Famulari <leo@famulari.name>
;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
;;; Copyright © 2020 Joseph LaFreniere <joseph@lafreniere.xyz>
@@ -458,6 +459,32 @@ such as readers and writers that fail after N consecutive reads/writes.")
custom assertions to be used alongside native Go testing.")
(license license:expat)))
+(define-public go-golang-org-sql-mock
+ (let ((commit "e98392b8111b45f8126e00af035a0dd95dc12e8b")
+ (version "1.3.3")
+ (revision "1"))
+ (package
+ (name "go-golang-org-sql-mock")
+ (version (git-version version revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/DATA-DOG/go-sqlmock")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "033vv29g2wf6fd757ajfmha30bqin3b07377037zkl051mk6mghs"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/DATA-DOG/go-sqlmock"))
+ (synopsis "Mock library implementing @code{sql/driver}")
+ (description "This library simulates SQL-driver behavior in tests
+without requiring a real database connection.")
+ (home-page "https://github.com/DATA-DOG/go-sqlmock")
+ (license license:expat))))
+
(define-public go-golang-org-x-lint
(let ((commit "83fdc39ff7b56453e3793356bcff3070b9b96445")
(revision "0"))