aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang-build.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-02-10 16:42:16 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-13 14:33:15 +0000
commitb900304377d66fc2d8cce52e86da34168893b54c (patch)
tree61027e3f886749cc1a5a62ea359e85d8663a9e82 /gnu/packages/golang-build.scm
parent2e8b550b56696ef1c8c53c53098bbfc14aaa3ccc (diff)
downloadguix-b900304377d66fc2d8cce52e86da34168893b54c.tar
guix-b900304377d66fc2d8cce52e86da34168893b54c.tar.gz
gnu: go-golang-org-x-xerrors: Move to golang-build.
* gnu/packages/golang.scm (go-golang-org-x-xerrors): Move from here ... * gnu/packages/golang-build.scm: ... to here. Change-Id: I68c9aa1607d71d08eb7ea4e5caf27121cdd0df4c
Diffstat (limited to 'gnu/packages/golang-build.scm')
-rw-r--r--gnu/packages/golang-build.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/golang-build.scm b/gnu/packages/golang-build.scm
index a8e97e7acb..fed606e8fb 100644
--- a/gnu/packages/golang-build.scm
+++ b/gnu/packages/golang-build.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2020 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2020 Ryan Prior <rprior@protonmail.com>
;;; Copyright © 2021 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2021 hackeryarn <artemchernyak@gmail.com>
;;; Copyright © 2023 Artyom V. Poptsov <poptsov.artyom@gmail.com>
@@ -195,6 +196,30 @@ loading algorithms.")
support for low-level interaction with the operating system.")
(license license:bsd-3))))
+(define-public go-golang-org-x-xerrors
+ (let ((commit "5ec99f83aff198f5fbd629d6c8d8eb38a04218ca")
+ (revision "0"))
+ (package
+ (name "go-golang-org-x-xerrors")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://go.googlesource.com/xerrors")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1dbzc3gmf2haazpv7cgmv97rq40g2xzwbglc17vas8dwhgwgwrzb"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "golang.org/x/xerrors"))
+ (home-page "https://godoc.org/golang.org/x/xerrors")
+ (synopsis "Go 1.13 error values")
+ (description "This package holds the transition packages for the new Go
+1.13 error values.")
+ (license license:bsd-3))))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar