aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang-build.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-02-05 17:30:31 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-13 14:16:27 +0000
commit5a77f2ee541b6a738fcf0dae762884825cd26d50 (patch)
tree73aac73bbf2003bf9abbb43653121f8e7c4b479f /gnu/packages/golang-build.scm
parente9a6c7094822bc859d0694eeaf8f434317219367 (diff)
downloadguix-5a77f2ee541b6a738fcf0dae762884825cd26d50.tar
guix-5a77f2ee541b6a738fcf0dae762884825cd26d50.tar.gz
gnu: Add (gnu packages golang-build) module.
* gnu/packages/golang-build.scm: New file. * gnu/local.mk: Add to gnu/packages/golang-build.scm scope. Change-Id: I4605d44452859b47ed6369a234c7ead496b19c2a
Diffstat (limited to 'gnu/packages/golang-build.scm')
-rw-r--r--gnu/packages/golang-build.scm44
1 files changed, 44 insertions, 0 deletions
diff --git a/gnu/packages/golang-build.scm b/gnu/packages/golang-build.scm
new file mode 100644
index 0000000000..03fcdede80
--- /dev/null
+++ b/gnu/packages/golang-build.scm
@@ -0,0 +1,44 @@
+;;; GNU Guix --- Functional package management for GNU
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages golang-build)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix build-system go)
+ #:use-module (guix gexp)
+ #:use-module (guix git-download)
+ #:use-module (guix packages)
+ #:use-module (guix utils)
+ #:use-module (gnu packages))
+
+;;; Commentary:
+;;;
+;;; Modules (libraries) which are part of the Golang project but outside the
+;;; main Golang tree, see <https://pkg.go.dev/golang.org/x>
+;;;
+;;; Since they are bound to be relied on by many, their dependencies should be
+;;; kept minimal, and this module should not depend on other modules
+;;; containing Golang packages.
+;;;
+;;; Please: Try to add new module packages in alphabetic order.
+;;;
+;;; Code:
+
+;;;
+;;; Avoid adding new packages to the end of this file. To reduce the chances
+;;; of a merge conflict, place them above by existing packages with similar
+;;; functionality or similar names.
+;;;