aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/gnuzilla.scm
diff options
context:
space:
mode:
authorAndré Batista <nandre@riseup.net>2024-09-19 19:39:05 -0300
committerJonathan Brielmaier <jonathan.brielmaier@web.de>2024-09-22 22:33:22 +0200
commitfc059c66cf8456aa7e456be8c3bc706c4e70fcaf (patch)
treee2676a38d27b26fa9327342a5153fc8ec509192d /gnu/packages/gnuzilla.scm
parentb7c94d528875415ea7ec6225d88a6b3d55fa2e14 (diff)
downloadguix-fc059c66cf8456aa7e456be8c3bc706c4e70fcaf.tar
guix-fc059c66cf8456aa7e456be8c3bc706c4e70fcaf.tar.gz
gnu: icedove-l10n: Fix build.
Fixes <https://issues.guix.gnu.org/73192> * gnu/packages/gnuzilla.scm (make-l10n-package)[arguments]<#:phases>: On 'build phase unconditionally use 'system*' to invoke 'mach', as 'invoke' does not work for icedove any longer. Reported-by: bdju <bdju@tilde.team>. Signed-off-by: Jonathan Brielmaier <jonathan.brielmaier@web.de>
Diffstat (limited to 'gnu/packages/gnuzilla.scm')
-rw-r--r--gnu/packages/gnuzilla.scm12
1 files changed, 5 insertions, 7 deletions
diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index d7b9aa72e9..d25577111b 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -1684,13 +1684,11 @@ their corresponding VERSION, SOURCE and LOCALES variables."
'thunderbird
'#$project))))
(format #t "processing locale `~a'...~%" l)
- (if (eq? 'icecat '#$project)
- ;; XXX: For some reasons, for IceCat, there are some
- ;; parsing errors that cause the build system to
- ;; return an unclean exit code; use system* to ignore
- ;; errors.
- (system* "./mach" "build" (string-append "langpack-" l))
- (invoke "./mach" "build" (string-append "langpack-" l)))
+ ;; XXX: For some reasons, on version 115, there are some
+ ;; parsing errors that cause the build system to
+ ;; return an unclean exit code; use system* to ignore
+ ;; errors.
+ (system* "./mach" "build" (string-append "langpack-" l))
(mkdir-p ext-dir)
(let ((xpi (find-file "obj" (string-append
"\\." l "\\.langpack\\.xpi$"))))