aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/gnustep.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-05-23 14:55:44 +0200
committerLudovic Courtès <ludo@gnu.org>2016-05-23 15:02:26 +0200
commitbc73a84398fa54b0a11a80c749bf78eb0a58dbe6 (patch)
tree3e7b6670989ceb4f31464bad632c0332121d96a0 /gnu/packages/gnustep.scm
parent12b6f6527e49c8c4191929a72b1692dbd9eb2440 (diff)
parent624d4e2e6ba402c374a340869306eec65a808a20 (diff)
downloadguix-bc73a84398fa54b0a11a80c749bf78eb0a58dbe6.tar
guix-bc73a84398fa54b0a11a80c749bf78eb0a58dbe6.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/gnustep.scm')
-rw-r--r--gnu/packages/gnustep.scm12
1 files changed, 10 insertions, 2 deletions
diff --git a/gnu/packages/gnustep.scm b/gnu/packages/gnustep.scm
index 31fca5b504..30574fca18 100644
--- a/gnu/packages/gnustep.scm
+++ b/gnu/packages/gnustep.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 Ludovic Courtès <ludo@gnu.org>
-;;; Copyright © 2016 Kei Yamashita <kei@openmailbox.org>
+;;; Copyright © 2016 Kei Kebreau <kei@openmailbox.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -101,7 +101,15 @@ interface. It is fast, feature rich, easy to configure, and easy to use.")
version ".orig.tar.gz"))
(sha256
(base32
- "0hi6bivv3xd2k68w08krndfl68wdx7nmc2wjzsmcd4q3qgwgyk44"))))
+ "0hi6bivv3xd2k68w08krndfl68wdx7nmc2wjzsmcd4q3qgwgyk44"))
+ (modules '((guix build utils)))
+ (snippet
+ ;; Fix memory leak:
+ ;; <https://lists.gnu.org/archive/html/guix-devel/2016-05/msg00466.html>.
+ '(substitute* "upower.c"
+ (("up = up_client_new\\(\\);")
+ (string-append "if (!up)\n"
+ " up = up_client_new();"))))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; no "check" target