aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/gnunet.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-03-09 20:36:21 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-03-31 21:25:50 -0400
commitaedb0879c29e3188645f34c9bea3d6dd9d8087da (patch)
treecc02fa15b9c027d28f0c0ee08d66d304c66a7a9e /gnu/packages/gnunet.scm
parentf0698ffb5279ed7747d49b48ef3f8a507916daa5 (diff)
downloadguix-aedb0879c29e3188645f34c9bea3d6dd9d8087da.tar
guix-aedb0879c29e3188645f34c9bea3d6dd9d8087da.tar.gz
gnu: gnunet: Update to 0.21.1.
* gnu/packages/gnunet.scm (gnunet): Update to 0.21.1. [phases]: Adjust disable-problematic-tests phase. Change-Id: Ia4b1c1ee9c3646e191669ea465d57acc006018e7
Diffstat (limited to 'gnu/packages/gnunet.scm')
-rw-r--r--gnu/packages/gnunet.scm22
1 files changed, 12 insertions, 10 deletions
diff --git a/gnu/packages/gnunet.scm b/gnu/packages/gnunet.scm
index 0bf524c148..758a809196 100644
--- a/gnu/packages/gnunet.scm
+++ b/gnu/packages/gnunet.scm
@@ -258,7 +258,7 @@ supports HTTP, HTTPS and GnuTLS.")
(define-public gnunet
(package
(name "gnunet")
- (version "0.20.0")
+ (version "0.21.1")
(source
(origin
(method url-fetch)
@@ -266,7 +266,7 @@ supports HTTP, HTTPS and GnuTLS.")
".tar.gz"))
(sha256
(base32
- "064mmhksznbsymanikwqkgmdhk2f0zjll2aq2cmxa14wm5w9w0jn"))))
+ "0p3q9590bm0d6q6p17jcbq2yiciqmvk5ys6pwdrp4257mhz8prlk"))))
(build-system gnu-build-system)
(inputs
(list bluez
@@ -306,15 +306,17 @@ supports HTTP, HTTPS and GnuTLS.")
#~(modify-phases %standard-phases
(add-after 'unpack 'disable-problematic-tests
(lambda _
- (substitute* "src/cadet/Makefile.in"
- ;; The speed_reliable tests appear to be unreliable (see:
- ;; https://bugs.gnunet.org/view.php?id=7787).
- (("test_cadet_[0-9]+_speed_reliable\\$\\(EXEEXT)")
+ ;; The 'test_communicator_bidirect-tcp' fails
+ ;; non-deterministically (see:
+ ;; https://bugs.gnunet.org/view.php?id=8689).
+ (substitute* "src/service/transport/Makefile.in"
+ (("test_communicator_bidirect-tcp\\$\\(EXEEXT) ")
""))
- (substitute* "src/core/Makefile.in"
- ;; The 'test_core_api' test fails non-deterministically (see:
- ;; https://bugs.gnunet.org/view.php?id=7784).
- (("test_core_api\\$\\(EXEEXT) ") ""))))
+ ;; The 'test_fs_search_with_and' fails non-deterministically
+ ;; (see: https://bugs.gnunet.org/view.php?id=8692).
+ (substitute* "src/service/fs/Makefile.in"
+ (("test_fs_search_with_and\\$\\(EXEEXT) ")
+ ""))))
(add-before 'check 'set-env-var-for-tests
(lambda _
(setenv "LANG" "en_US.UTF-8")))