aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorVivien Kraus <vivien@planete-kraus.eu>2023-10-31 20:34:25 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-11-02 18:57:42 +0100
commitea51a3885c56c669f8558592d0ac13a1aae0e548 (patch)
tree081c9540ec4add322eaf884b67c58bf0deac8f29 /gnu/packages/gnome.scm
parent8cd5eebd11f8cf72c0b560e5bca538a8615edf83 (diff)
downloadguix-ea51a3885c56c669f8558592d0ac13a1aae0e548.tar
guix-ea51a3885c56c669f8558592d0ac13a1aae0e548.tar.gz
gnu: Add gmobile.
* gnu/packages/gnome.scm (gmobile): New variable. * gnu/packages/patches/gmobile-make-it-installable.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it here. Change-Id: If36413dfa1ee1e6156f2652fa86282283b592b36 Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 77908768b7..6761ffa5dc 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -12915,6 +12915,33 @@ both peers support it. You might want that when communicating on a single
host to avoid parser overhead and memory-allocator fragmentation.")
(license license:lgpl2.1+)))
+(define-public gmobile
+ (package
+ (name "gmobile")
+ (version "0.0.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.gnome.org/guidog/gmobile")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name "gmobile" version))
+ (sha256
+ (base32
+ "0lr22nj4ypzxbjim1a7ay07nh4vx3dqc895qql437gda6x0rvn2p"))
+ (patches
+ (search-patches "gmobile-make-it-installable.patch"))))
+ (build-system meson-build-system)
+ (native-inputs
+ (list `(,glib "bin") ; for glib-compile-resources
+ pkg-config))
+ (propagated-inputs
+ (list glib json-glib))
+ (synopsis "Functions useful in mobile related, glib based projects")
+ (description "This package provides functions for mobiles.")
+ (home-page "https://gitlab.gnome.org/guidog/gmobile")
+ (license license:lgpl2.1+)))
+
(define-public feedbackd
(package
(name "feedbackd")