aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2024-03-31 16:48:21 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2024-04-06 06:36:42 +0200
commitcee21ef8650d723e9e1ea4c6313897fd3bf64112 (patch)
tree61692ea6a40fbf747a0187b1561f310164d191c3 /gnu/packages/gnome.scm
parentd92bb7c542aaf0282f08be78853b9ca7c5d7a159 (diff)
downloadguix-cee21ef8650d723e9e1ea4c6313897fd3bf64112.tar
guix-cee21ef8650d723e9e1ea4c6313897fd3bf64112.tar.gz
gnu: blueprint-compiler: Update to 0.12.0.
* gnu/packages/gnome.scm (blueprint-compiler): Update to 0.12.0. [arguments]: Remove ‘wrap-gi’ phase, add ‘pre-check’. [native-inputs]: Add libadwaita and xorg-server-for-tests. Reindent. Reviewed-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm20
1 files changed, 11 insertions, 9 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index bdc84524a3..437fdf499a 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -3278,7 +3278,7 @@ the GNOME desktop environment.")
(define-public blueprint-compiler
(package
(name "blueprint-compiler")
- (version "0.4.0")
+ (version "0.12.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -3288,7 +3288,7 @@ the GNOME desktop environment.")
(file-name (string-append name "-" version "-checkout"))
(sha256
(base32
- "0hj7f4xhwjc4x32r3lswwclbw37fw3spy806g4plkmym25hz4ydy"))))
+ "15cm2bksmygf8sifryrawxxblvvw27p4w3m42gvp3jlq50a15xm6"))))
(build-system meson-build-system)
(arguments
(list
@@ -3303,13 +3303,15 @@ the GNOME desktop environment.")
#~(modify-phases %standard-phases
(add-after 'wrap 'wrap-python
(assoc-ref python:%standard-phases 'wrap))
- (add-after 'wrap-python 'wrap-gi
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out"))
- (gi-typelib-path (getenv "GI_TYPELIB_PATH")))
- (wrap-program (string-append out "/bin/blueprint-compiler")
- `("GI_TYPELIB_PATH" ":" suffix (,gi-typelib-path)))))))))
- (native-inputs (list gtk python-pygobject python))
+ (add-before 'check 'pre-check
+ (lambda _
+ (system "Xvfb :1 &")
+ (setenv "DISPLAY" ":1"))))))
+ (native-inputs (list gtk
+ libadwaita
+ python
+ python-pygobject
+ xorg-server-for-tests))
(inputs (list python))
(synopsis "Template markup language")
(description