aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2024-01-25 16:55:44 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2024-02-23 23:22:48 +0100
commita7ab8e4f4893c1220eefe831d24bd9cf7064d39f (patch)
tree8d01590336bdd822e297b77728431c66ab6909ab /gnu/packages/gnome.scm
parent96634bb878f43841f8b3e298216072a3f43b7975 (diff)
downloadguix-a7ab8e4f4893c1220eefe831d24bd9cf7064d39f.tar
guix-a7ab8e4f4893c1220eefe831d24bd9cf7064d39f.tar.gz
gnu: Deprecate gnome meta-package.
GNOME is not a "one size fits all" environment, but with the introduction of World, Circle, and to some extent Developer Extras and recent explorations of mobile form factors much more customizable towards the needs of users. As such, it is silly to insist on a single meta-package to make everyone happy. * gnu/packages/gnome.scm (gnome): Deprecate.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 5c6eb2288a..c3707ea632 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -237,6 +237,7 @@
#:use-module (guix build-system meson)
#:use-module (guix build-system python)
#:use-module (guix build-system trivial)
+ #:use-module (guix deprecation)
#:use-module (guix download)
#:use-module (guix git-download)
#:use-module ((guix licenses) #:prefix license:)
@@ -10284,7 +10285,7 @@ documents and diagrams, playing media, scanning, and much more.")
a good GNOME experience, mixed from core dependencies and other implicitly
relied-on packages.")))
-(define-public gnome
+(define-deprecated/public gnome #f
(gnome-meta-package
(name "gnome")
(propagated-inputs