aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorRaghav Gururajan <raghavgururajan@disroot.org>2019-12-27 12:16:07 -0500
committerJulien Lepiller <julien@lepiller.eu>2019-12-28 16:19:20 +0100
commit76ea7632215e65197839657ee8748d51b1caf5cd (patch)
tree6daa60608013389a4377cbbad5cea4d7400433c7 /gnu/packages/gnome.scm
parent04a51d0c83785ed2d65892821b6826196ddce47b (diff)
downloadguix-76ea7632215e65197839657ee8748d51b1caf5cd.tar
guix-76ea7632215e65197839657ee8748d51b1caf5cd.tar.gz
gnu: Add gnome-themes-extra
* gnu/packages/gnome.scm (gnome-themes-extra): New Variable. Signed-off-by: Julien Lepiller <julien@lepiller.eu>
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 76b3f4aa77..ede98f4633 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -9074,6 +9074,38 @@ and a high score table.")
(home-page "https://wiki.gnome.org/Apps/Mahjongg")
(license license:gpl2+)))
+(define-public gnome-themes-extra
+ (package
+ (name "gnome-themes-extra")
+ (version "3.28")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/" name "-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "06aqg9asq2vqi9wr29bs4v8z2bf4manhbhfghf4nvw01y2zs0jvw"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("glib:bin" ,glib "bin")
+ ("intltool" ,intltool)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("glib" ,glib)
+ ("gtk+" ,gtk+)
+ ("gtk+-2" ,gtk+-2)
+ ("librsvg" ,librsvg)
+ ("libxml2" ,libxml2)))
+ (home-page "https://gitlab.gnome.org/GNOME/gnome-themes-extra")
+ (synopsis "GNOME Extra Themes")
+ (description "This package provides themes and related elements that don't
+really fit in other upstream packages. It offers legacy support for GTK+ 2
+versions of Adwaita, Adwaita-dark and HighContrast themes. It also provides
+index files needed for Adwaita to be used outside of GNOME.")
+ (license license:lgpl2.1+)))
+
(define-public polari
(package
(name "polari")