aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorHerman Rimm <herman@rimm.ee>2024-03-15 19:33:27 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2024-03-23 05:16:30 +0100
commit5b26305e0ea63ff0291d48588968e7ba6a6d2eda (patch)
treee57f08da68a73c9f47bce036c1362719efd28b3c /gnu/packages/gnome.scm
parenta9951a74a591a9b22ee2d93d8efe0523c6c42c97 (diff)
downloadguix-5b26305e0ea63ff0291d48588968e7ba6a6d2eda.tar
guix-5b26305e0ea63ff0291d48588968e7ba6a6d2eda.tar.gz
gnu: libsecret: Update to 0.21.4.
* gnu/packages/gnome.scm (libsecret): Update. Change-Id: I8a785f1fa9ff9ddde6dfda9a52abd0405b5ab448 Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm10
1 files changed, 2 insertions, 8 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 5432ebc27b..5e7c0e93df 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5191,7 +5191,7 @@ and the GLib main loop, to integrate well with GNOME applications.")
(define-public libsecret
(package
(name "libsecret")
- (version "0.20.5")
+ (version "0.21.4")
(source (origin
(method url-fetch)
(uri (string-append
@@ -5200,7 +5200,7 @@ and the GLib main loop, to integrate well with GNOME applications.")
"libsecret-" version ".tar.xz"))
(sha256
(base32
- "0k9bs47rzb3dwvznb4179d6nw7rbzjdyd4y8hx6vazfd1wscxcrz"))))
+ "081bj59ws08kb261cd1w1mkdkhfbzsjbbkkrm6wllvdyhgbhhg8n"))))
(build-system meson-build-system)
(arguments
(list
@@ -5208,12 +5208,6 @@ and the GLib main loop, to integrate well with GNOME applications.")
#~(list "-Dgtk_doc=false") ;requires gi-docgen
#:phases
#~(modify-phases %standard-phases
- (add-after 'unpack 'disable-problematic-tests
- (lambda _
- (substitute* "libsecret/meson.build"
- ;; The test-collection test fails non-deterministically (see:
- ;; https://gitlab.gnome.org/GNOME/libsecret/-/issues/80).
- ((".*'test-collection',.*") ""))))
(delete 'check)
(add-after 'install 'check
(lambda* (#:key tests? test-options #:allow-other-keys)