aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/gnome-xyz.scm
diff options
context:
space:
mode:
authorVivien Kraus <vivien@planete-kraus.eu>2024-01-16 22:47:02 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2024-01-19 23:46:42 +0100
commitb2b488b108fd3f7ac2b2728b091f06a0bf82e715 (patch)
treea604c3a8ce80a4756c346420c64647c937b889fc /gnu/packages/gnome-xyz.scm
parentefd3dc654ad88e40cb78dbe804cd7627a5153b8a (diff)
downloadguix-b2b488b108fd3f7ac2b2728b091f06a0bf82e715.tar
guix-b2b488b108fd3f7ac2b2728b091f06a0bf82e715.tar.gz
gnu: gnome-shell-extensions-customize-ibus: Update to 86.
* gnu/packages/gnome-xyz.scm (gnome-shell-extension-customize-ibus): Update to 86. [arguments]: Convert to list of G-Expressions. [native-inputs]: Drop labels. [propagated-inputs]: Add ibus. Change-Id: I48dbc2bd9a8dea7e7a2b161089b433e1d72a8ff1 Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
Diffstat (limited to 'gnu/packages/gnome-xyz.scm')
-rw-r--r--gnu/packages/gnome-xyz.scm21
1 files changed, 12 insertions, 9 deletions
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 7d7475c9be..9a6eea8cb2 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -61,6 +61,7 @@
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
#:use-module (gnu packages gtk)
+ #:use-module (gnu packages ibus)
#:use-module (gnu packages inkscape)
#:use-module (gnu packages image)
#:use-module (gnu packages pkg-config)
@@ -649,7 +650,7 @@ that caches clipboard history.")
(define-public gnome-shell-extension-customize-ibus
(package
(name "gnome-shell-extension-customize-ibus")
- (version "82")
+ (version "86")
(source
(origin
(method git-fetch)
@@ -658,21 +659,23 @@ that caches clipboard history.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "00brnyahphl4ql9yh74wpb9kmzyb4b5k4rkw40hvxvqw4qwgs24r"))))
+ (base32 "1psnbhqbqrp68dri0q98y7ikwz9z3701lcy8vvgixb2bh71y7519"))))
(build-system gnu-build-system)
(arguments
- `(#:make-flags
- (list (string-append "VERSION=" ,version)
- (string-append "INSTALLBASE=" (assoc-ref %outputs "out")
- "/share/gnome-shell/extensions"))
+ (list
+ #:make-flags
+ #~(list (string-append "VERSION=" #$version)
+ (string-append "INSTALLBASE=" #$output
+ "/share/gnome-shell/extensions"))
#:tests? #f ; No test target
#:phases
- (modify-phases %standard-phases
+ #~(modify-phases %standard-phases
(delete 'bootstrap)
(delete 'configure))))
(native-inputs
- `(("gettext" ,gettext-minimal)
- ("glib:bin" ,glib "bin")))
+ (list gettext-minimal `(,glib "bin")))
+ (propagated-inputs
+ (list ibus))
(home-page "https://github.com/openSUSE/Customize-IBus")
(synopsis "GNOME Shell Extension for IBus Customization")
(description "Customize IBus provides full customization of appearance,