aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/gnome-xyz.scm
diff options
context:
space:
mode:
authorVivien Kraus <vivien@planete-kraus.eu>2024-01-17 22:57:17 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2024-01-20 00:38:12 +0100
commit839388b0333ec5d70b1ef08c9c5d4753084f365a (patch)
tree014d956bc99da0fa4921abe65dfbb1564ab66750 /gnu/packages/gnome-xyz.scm
parentb086d1ba9ea6e036ff7afe5bc4cf92a9dec70374 (diff)
downloadguix-839388b0333ec5d70b1ef08c9c5d4753084f365a.tar
guix-839388b0333ec5d70b1ef08c9c5d4753084f365a.tar.gz
gnu: gnome-shell-extension-burn-my-windows: Update to 40.
* gnu/packages/gnome-xyz.scm (gnome-shell-extension-burn-my-windows): Update to 40. [arguments]: Convert to list of G-Expressions. Change-Id: Ib9551096437aeea0ff56e5e1ea6371ab72d61b02 Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
Diffstat (limited to 'gnu/packages/gnome-xyz.scm')
-rw-r--r--gnu/packages/gnome-xyz.scm35
1 files changed, 18 insertions, 17 deletions
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index de7f4a5f86..f221da2c98 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -1183,7 +1183,7 @@ position when the mouse is moved rapidly.")
(define-public gnome-shell-extension-burn-my-windows
(package
(name "gnome-shell-extension-burn-my-windows")
- (version "22")
+ (version "40")
(source
(origin
(method git-fetch)
@@ -1192,25 +1192,26 @@ position when the mouse is moved rapidly.")
(commit (string-append "v" version))))
(sha256
(base32
- "185xrf330d9bflmk0l61cnzlylnppb2v4yz6v6ygkk4zpwyil8np"))
+ "16n6ilszdn67835clqlr4flna69x9k00k5qrm55765dv2ny9jdcq"))
(file-name (git-file-name name version))))
(build-system copy-build-system)
(arguments
- `(#:install-plan
- '(("." ,(string-append
- "share/gnome-shell/extensions/"
- "burn-my-windows@schneegans.github.com")
- #:include-regexp ("\\.js(on)?$" "\\.css$" "\\.ui$" "\\.png$"
- "\\.xml$" "\\.compiled$" "\\.gresource$")))
- #:phases
- (modify-phases %standard-phases
- (add-before 'install 'compile-resources
- (lambda _
- (invoke "make" "resources/burn-my-windows.gresource")))
- (add-before 'install 'compile-schemas
- (lambda _
- (with-directory-excursion "schemas"
- (invoke "glib-compile-schemas" ".")))))))
+ (list
+ #:install-plan
+ #~'(("." #$(string-append
+ "share/gnome-shell/extensions/"
+ "burn-my-windows@schneegans.github.com")
+ #:include-regexp ("\\.js(on)?$" "\\.css$" "\\.ui$" "\\.png$"
+ "\\.xml$" "\\.compiled$" "\\.gresource$")))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'install 'compile-resources
+ (lambda _
+ (invoke "make" "resources/burn-my-windows.gresource")))
+ (add-before 'install 'compile-schemas
+ (lambda _
+ (with-directory-excursion "schemas"
+ (invoke "glib-compile-schemas" ".")))))))
(native-inputs
(list `(,glib "bin"))) ; for glib-compile-resources
(home-page "https://github.com/Schneegans/Burn-My-Windows")