aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/gnome-xyz.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2023-09-07 20:42:02 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-09-07 20:42:03 +0200
commit20e3f3e1151b2f22ae7fb5aa8764148654f35090 (patch)
tree3f6af3a73f4548b8f6564a31984abeeefd60b0ef /gnu/packages/gnome-xyz.scm
parent965e2d6eb90826181471b834437ac68dcb9217cb (diff)
parent451ba2e5bb523c18a2ccc941df47b598c48ef57e (diff)
downloadguix-20e3f3e1151b2f22ae7fb5aa8764148654f35090.tar
guix-20e3f3e1151b2f22ae7fb5aa8764148654f35090.tar.gz
Merge branch 'master' into gnome-team
Diffstat (limited to 'gnu/packages/gnome-xyz.scm')
-rw-r--r--gnu/packages/gnome-xyz.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 9e13bcb59d..77d6aecc50 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -240,6 +240,39 @@ simple and consistent.")
and a few extra features.")
(license license:gpl3)))
+(define-public qogir-icon-theme
+ (package
+ (name "qogir-icon-theme")
+ (version "2023.06.05")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/vinceliuice/Qogir-icon-theme")
+ (commit (string-replace-substring version "." "-"))))
+ (file-name (git-file-name name version))
+ (modules '((guix build utils)))
+ (snippet '(substitute* "install.sh"
+ (("gtk-update-icon-cache") "true")))
+ (sha256
+ (base32
+ "1kn8b9zdamxbfbs7b9qpx53hmjw2l40sxpjw93axb1dqy81yc8da"))))
+ (build-system copy-build-system)
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (replace 'install
+ (lambda _
+ (let* ((dest (string-append #$output "/share/icons"))
+ (flags (list "--theme" "all"
+ "--color" "all"
+ "--dest" dest)))
+ (mkdir-p dest)
+ (apply invoke "bash" "install.sh" flags)))))))
+ (home-page "https://www.pling.com/p/1296407/")
+ (synopsis "Flat colorful design icon theme")
+ (description "This package provides a flat colorful design icon theme.")
+ (license license:gpl3)))
+
(define-public flat-remix-icon-theme
(package
(name "flat-remix-icon-theme")