aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/glib.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2017-10-25 20:02:08 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2017-10-25 20:02:08 +0200
commitb7883b111d92746ff3bedb6f4bb4c1578068fc59 (patch)
tree37690ae3dd18cbbba3abe68986ae32b913afd407 /gnu/packages/glib.scm
parentc27e8c1abd8ad66dbfce3ef56ee0fd8919906e3b (diff)
parent63bbf38fb177bc28e6b8c8692815812e636d6e18 (diff)
downloadguix-b7883b111d92746ff3bedb6f4bb4c1578068fc59.tar
guix-b7883b111d92746ff3bedb6f4bb4c1578068fc59.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/glib.scm')
-rw-r--r--gnu/packages/glib.scm61
1 files changed, 60 insertions, 1 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index 6024c7600f..cef6d7bea0 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -5,6 +5,8 @@
;;; Copyright © 2014, 2015, 2016, 2017 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Lukas Gradl <lgradl@openmailbox.org>
+;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2017 Petter <petter@mykolab.ch>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -27,6 +29,7 @@
#:use-module (guix download)
#:use-module (guix utils)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system perl)
#:use-module (guix build-system python)
#:use-module (gnu packages)
#:use-module (gnu packages base)
@@ -62,7 +65,9 @@
itstool
libsigc++
glibmm
- telepathy-glib))
+ telepathy-glib
+ perl-net-dbus
+ perl-net-dbus-glib))
(define dbus
(package
@@ -745,3 +750,57 @@ programming langauage. It also contains the utility
reading and writing @uref{https://www.freedesktop.org/wiki/Distributions/AppStream,AppStream}
metadata.")
(license license:lgpl2.1+)))
+
+(define perl-net-dbus
+ (package
+ (name "perl-net-dbus")
+ (version "1.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/D/DA/DANBERR/Net-DBus-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0sg2w147b9r9ykfzjs7y9qxry73xkjnhnk4qf95kfv79p5nnk4c3"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("perl-test-pod" ,perl-test-pod)
+ ("perl-test-pod-coverage" ,perl-test-pod-coverage)))
+ (inputs
+ `(("dbus" ,dbus)))
+ (propagated-inputs
+ `(("perl-xml-twig" ,perl-xml-twig)))
+ (home-page "http://search.cpan.org/dist/Net-DBus/")
+ (synopsis "Extension for the DBus bindings")
+ (description "@code{Net::DBus} provides a Perl XS API to the DBus
+inter-application messaging system. The Perl API covers the core base level
+of the DBus APIs, not concerning itself yet with the GLib or QT wrappers.")
+ (license license:perl-license)))
+
+(define perl-net-dbus-glib
+ (package
+ (name "perl-net-dbus-glib")
+ (version "0.33.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/D/DA/DANBERR/"
+ "Net-DBus-GLib-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1z4mbv8z0rad604xahijpg5szzi8qak07hbahh230z4jf96fkxvj"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("dbus-glib" ,dbus-glib)))
+ (home-page "http://search.cpan.org/~danberr/Net-DBus-GLib-0.33.0/")
+ (synopsis "Perl extension for the DBus GLib bindings")
+ (description "This package provides an extension to the @code{Net::DBus}
+module allowing integration with the GLib mainloop. To integrate with the
+main loop, simply get a connection to the bus via the methods in
+@code{Net::DBus::GLib} rather than the usual @code{Net::DBus} module. Every
+other API remains the same.")
+ (license license:gpl2+)))