aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/glib.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-08-31 12:46:08 +0200
committerAndreas Enge <andreas@enge.fr>2013-08-31 12:46:08 +0200
commit24b5c463f3b70e2d2da1219bf32db28f5bb4582c (patch)
tree29d6a737608100cadf8a8ada73b93cb7985b5ceb /gnu/packages/glib.scm
parentd9c4b6e944918532382f999735b040125dc6ebe0 (diff)
downloadguix-24b5c463f3b70e2d2da1219bf32db28f5bb4582c.tar
guix-24b5c463f3b70e2d2da1219bf32db28f5bb4582c.tar.gz
gnu: Add dbus-glib.
* gnu/packages/glib.scm (dbus-glib): New variable.
Diffstat (limited to 'gnu/packages/glib.scm')
-rw-r--r--gnu/packages/glib.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index 15031179ff..63751bb510 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -185,3 +185,28 @@ The intltool collection can be used to do these things:
Merge back the translations from .po files into .xml, .desktop and
oaf files. This merge step will happen at build resp. installation time.")
(license license:gpl2+)))
+
+(define-public dbus-glib
+ (package
+ (name "dbus-glib")
+ (version "0.100.2")
+ (source (origin
+ (method url-fetch)
+ (uri
+ (string-append "http://dbus.freedesktop.org/releases/dbus-glib/dbus-glib-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1ibav91yg70f2l3l18cr0hf4mna1h9d4mrg0c60w4l8zjbd45fx5"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("dbus" ,dbus)
+ ("expat" ,expat)
+ ("glib" ,glib)
+ ("pkg-config" ,pkg-config)))
+ (home-page "http://dbus.freedesktop.org/doc/dbus-glib/")
+ (synopsis "D-Bus GLib bindings")
+ (description
+ "GLib bindings for D-Bus. The package is obsolete and superseded
+by GDBus included in Glib.")
+ (license license:gpl2))) ; or Academic Free License 2.1