aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/gl.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2024-01-25 10:19:29 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2024-02-03 10:55:06 +0100
commit8deec946542700d5a9ddf98df3a3a6684cd13dd8 (patch)
tree26d8d52c286e863c67b6eedd0a51b3458adc3abd /gnu/packages/gl.scm
parent6ce2bd76c0e51bdfe77b9c19d70f8a25d4d007e9 (diff)
downloadguix-8deec946542700d5a9ddf98df3a3a6684cd13dd8.tar
guix-8deec946542700d5a9ddf98df3a3a6684cd13dd8.tar.gz
gnu: Add piglit.
* gnu/packages/gl.scm (piglit): New variable.
Diffstat (limited to 'gnu/packages/gl.scm')
-rw-r--r--gnu/packages/gl.scm52
1 files changed, 52 insertions, 0 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 35fb1e618c..f8dc8c1d9d 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -1248,3 +1248,55 @@ original glmark benchmark by Ben Smith.")
(description "Waffle is a library that allows one to defer selection of an
OpenGL API and a window system until runtime.")
(license license:bsd-2)))
+
+(define-public piglit
+ (let ((revision "1")
+ (commit "814046fe6942eac660ee4a6cc5fcc54011a49945"))
+ (package
+ (name "piglit")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.freedesktop.org/mesa/piglit")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1bzaalcxskckfnwprw77sbbmfqi59by2j8imaq8ghnlzhlxv7mk7"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list #:configure-flags #~(list "-DPIGLIT_SSE2=OFF")
+ ;; Tests are not invoked through cmake. Instead, there are
+ ;; pytest/tox-based tests for the framework, but they require
+ ;; unpackaged plugins.
+ #:tests? #f
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-source
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* (find-files "framework/" "\\.py$")
+ (("'wflinfo'")
+ (string-append "'"
+ (search-input-file inputs "/bin/wflinfo")
+ "'")))))
+ (add-after 'install 'wrap
+ (lambda* (#:key outputs #:allow-other-keys)
+ (wrap-script (string-append (assoc-ref outputs "out")
+ "/bin/piglit")
+ `("GUIX_PYTHONPATH" prefix
+ (,(getenv "GUIX_PYTHONPATH")))))))))
+ (inputs (list guile-3.0 ; for wrap-script
+ libxkbcommon
+ python python-lxml python-mako python-numpy
+ glslang vulkan-headers vulkan-loader
+ waffle))
+ (native-inputs (list pkg-config))
+ (home-page "https://piglit.freedesktop.org/")
+ (synopsis "Test OpenGL implementations")
+ (description "Piglit is a collection of automated tests for OpenGL and
+OpenCL implementations.")
+ ;; A mix of licenses for various tests
+ (license (list license:expat
+ license:bsd-3
+ license:gpl2+
+ license:gpl3+)))))