aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/gl.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2023-03-02 10:37:28 +0000
committerChristopher Baines <mail@cbaines.net>2023-03-02 10:55:08 +0000
commit7df09ee0ab3e7962ef27859ce87e06a323059284 (patch)
treed81334f742ddcb9a1ee63961ca6410922980af1c /gnu/packages/gl.scm
parent2ac51ec99b58b50c08ba719a8c7e9dba0330b065 (diff)
parentaf95f2d8f98eb2c8c64954bb2fd0b70838899174 (diff)
downloadguix-7df09ee0ab3e7962ef27859ce87e06a323059284.tar
guix-7df09ee0ab3e7962ef27859ce87e06a323059284.tar.gz
Merge remote-tracking branch 'savannah/master' into core-updates
Conflicts: gnu/local.mk gnu/packages/autotools.scm gnu/packages/cmake.scm gnu/packages/gnuzilla.scm gnu/packages/haskell.scm gnu/packages/pdf.scm gnu/packages/python-xyz.scm gnu/packages/samba.scm gnu/packages/tex.scm gnu/packages/tls.scm gnu/packages/wxwidgets.scm
Diffstat (limited to 'gnu/packages/gl.scm')
-rw-r--r--gnu/packages/gl.scm31
1 files changed, 28 insertions, 3 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 5151ecdce4..3ffdd8346d 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -64,7 +64,6 @@
#:use-module (guix build-system cmake)
#:use-module (guix build-system meson)
#:use-module (guix build-system python)
- #:use-module (guix build-system waf)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix gexp)
@@ -128,7 +127,7 @@ as ASCII text.")
(propagated-inputs
;; Headers from Mesa and GLU are needed.
(list glu mesa))
- (home-page "http://freeglut.sourceforge.net/")
+ (home-page "https://freeglut.sourceforge.net/")
(synopsis "Alternative to the OpenGL Utility Toolkit (GLUT)")
(description
"Freeglut is a completely Free/OpenSourced alternative to
@@ -785,6 +784,32 @@ Both GLX and EGL are supported, in any combination with OpenGL and OpenGL ES.")
license:x11
license:expat))))
+(define-public libopenglrecorder
+ (package
+ (name "libopenglrecorder")
+ (version "0.1.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Benau/libopenglrecorder")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0sfx2kdw2mca3mx4fnk1yy74pilp2i9npcpyj894qkngz5aaz2wl"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list #:tests? #f)) ;no test suite
+ (native-inputs (list pkg-config))
+ (inputs (list libjpeg-turbo))
+ (home-page "https://github.com/Benau/libopenglrecorder")
+ (synopsis "Async readback OpenGL frame buffer with audio recording")
+ (description
+ "libopenglrecorder is a library allowing optional async readback OpenGL
+frame buffer with optional audio recording. It will do video and audio
+encoding together.")
+ (license license:bsd-3)))
+
(define-public soil
(package
(name "soil")
@@ -909,7 +934,7 @@ and visualizations.")
(list libpng mesa zlib))
(arguments
`(#:tests? #f)) ; no tests
- (home-page "http://www.geuz.org/gl2ps/")
+ (home-page "https://www.geuz.org/gl2ps/")
(synopsis "OpenGL to PostScript printing library")
(description "GL2PS is a C library providing high quality vector
output for any OpenGL application. GL2PS uses sorting algorithms