aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/gl.scm
diff options
context:
space:
mode:
authorKaelyn Takata <kaelyn.alexi@protonmail.com>2023-05-04 20:12:46 +0000
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-05-07 13:04:24 -0400
commit0be7838105806819f4586ec9130382a66a22880e (patch)
tree6caacfdb50cb993fef338ef6da4162892034b718 /gnu/packages/gl.scm
parentcf79468720fc33a5061a174fccb1ffba1914c434 (diff)
downloadguix-0be7838105806819f4586ec9130382a66a22880e.tar
guix-0be7838105806819f4586ec9130382a66a22880e.tar.gz
gnu: mesa: Update to 23.0.3.
* gnu/packages/gl.scm (mesa): Update to 23.0.3. [source]: Remove obsolete patch and update HTTPS url. [arguments]: Enable the crocus gallium driver. * gnu/packages/patches/mesa-fix-sporadic-test-failures.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages/gl.scm')
-rw-r--r--gnu/packages/gl.scm14
1 files changed, 5 insertions, 9 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 5248151a95..235b386dad 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -267,21 +267,17 @@ also known as DXTn or DXTC) for Mesa.")
(define-public mesa
(package
(name "mesa")
- (version "22.2.4")
+ (version "23.0.3")
(source
(origin
(method url-fetch)
- (uri (list (string-append "https://mesa.freedesktop.org/archive/"
+ (uri (list (string-append "https://archive.mesa3d.org/"
"mesa-" version ".tar.xz")
(string-append "ftp://ftp.freedesktop.org/pub/mesa/"
- "mesa-" version ".tar.xz")
- (string-append "ftp://ftp.freedesktop.org/pub/mesa/"
- version "/mesa-" version ".tar.xz")))
+ "mesa-" version ".tar.xz")))
(sha256
(base32
- "1azpr68pdg63yq3igmzwsgn2ypg49m0mp3hfkq0lcyswr99npmv5"))
- (patches
- (list (search-patch "mesa-fix-sporadic-test-failures.patch")))))
+ "1mcjf41x2bhxs6yxars7nh2vfryfw50g6rvbcfbb1wqdv2jn4qrq"))))
(build-system meson-build-system)
(propagated-inputs
;; The following are in the Requires.private field of gl.pc.
@@ -330,7 +326,7 @@ r300,r600,swrast,tegra,v3d,vc4,virgl"))
((or "powerpc64le-linux" "powerpc-linux" "riscv64-linux")
'("-Dgallium-drivers=nouveau,r300,r600,radeonsi,swrast,virgl"))
(_
- '("-Dgallium-drivers=iris,nouveau,r300,r600,radeonsi,\
+ '("-Dgallium-drivers=crocus,iris,nouveau,r300,r600,radeonsi,\
svga,swrast,virgl")))
;; Enable various optional features. TODO: opencl requires libclc,
;; omx requires libomxil-bellagio