aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/gl.scm
diff options
context:
space:
mode:
authorSigve Sudland <sigve_sudland@hotmail.com>2023-07-19 23:02:34 +0200
committerJohn Kehayias <john.kehayias@protonmail.com>2023-07-29 21:18:14 -0400
commit090c254fe7713db330636dae2c204c8282207cc8 (patch)
tree94fbd98cdad6fe33e3beacdc53da2fd112d48a2c /gnu/packages/gl.scm
parent9d4cd681daaa8c368858f8f718773a71494743dd (diff)
downloadguix-090c254fe7713db330636dae2c204c8282207cc8.tar
guix-090c254fe7713db330636dae2c204c8282207cc8.tar.gz
gnu: mesa: Enable zstd compression for shader cache.
* gnu/packages/gl.scm (mesa)[inputs]: Add zstd:lib. [arguments]: Add '-Dzstd=enabled' to configure-flags. Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
Diffstat (limited to 'gnu/packages/gl.scm')
-rw-r--r--gnu/packages/gl.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 9325d41907..86be6e0bb1 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -298,7 +298,8 @@ also known as DXTn or DXTC) for Mesa.")
libxvmc
llvm-for-mesa
wayland
- wayland-protocols))
+ wayland-protocols
+ `(,zstd "lib")))
(native-inputs
(list bison
flex
@@ -362,6 +363,9 @@ svga,swrast,virgl")))
;; 21.3.x releases to avoid functionality regressions.
"-Dvideo-codecs=vc1dec,h264dec,h264enc,h265dec,h265enc"
+ ;; Enable ZSTD compression for shader cache.
+ "-Dzstd=enabled"
+
;; Also enable the tests.
"-Dbuild-tests=true"