aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/ghostscript.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2019-07-02 16:20:19 +0200
committerMathieu Othacehe <m.othacehe@gmail.com>2019-09-24 08:14:12 +0200
commit3fe8fe5360a0c53296d807a5109d6a94adc5d95f (patch)
treef2efc0e7959e0fef49eb3c3102a248c0af61fdae /gnu/packages/ghostscript.scm
parente373adc13969bb8d5bf7c040fb32b8a51b40c91b (diff)
downloadguix-3fe8fe5360a0c53296d807a5109d6a94adc5d95f.tar
guix-3fe8fe5360a0c53296d807a5109d6a94adc5d95f.tar.gz
gnu: libpaper: Fix aarch64 cross-compilation.
The packaged config.sub and config.guess do not have aarch64 support. Replace them by the ones from automake. * gnu/packages/ghostscript.scm (libpaper)[arguments]: Replace outdated config.sub and config.guess, taken from ... [native-inputs]: ... here, by adding automake.
Diffstat (limited to 'gnu/packages/ghostscript.scm')
-rw-r--r--gnu/packages/ghostscript.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/ghostscript.scm b/gnu/packages/ghostscript.scm
index 3b74a96966..7839ac5b72 100644
--- a/gnu/packages/ghostscript.scm
+++ b/gnu/packages/ghostscript.scm
@@ -8,6 +8,7 @@
;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -84,6 +85,24 @@ Consortium standard (ICC), approved as ISO 15076-1.")
(sha256 (base32
"0zhcx67afb6b5r936w5jmaydj3ks8zh83n9rm5sv3m3k8q8jib1q"))))
(build-system gnu-build-system)
+ (native-inputs
+ `(("automake" ,automake))) ; For up to date 'config.guess' and 'config.sub'.
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-configure
+ (lambda* (#:key inputs native-inputs #:allow-other-keys)
+ ;; Replace outdated config.sub and config.guess:
+ (for-each (lambda (file)
+ (install-file
+ (string-append (assoc-ref
+ (or native-inputs inputs) "automake")
+ "/share/automake-"
+ ,(version-major+minor
+ (package-version automake))
+ "/" file) "."))
+ '("config.sub" "config.guess"))
+ #t)))))
(synopsis "Library for handling paper sizes")
(description
"The paper library and accompanying files are intended to provide a simple