aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/ghostscript.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-07-06 22:45:54 +0200
committerMarius Bakke <marius@gnu.org>2022-07-16 23:25:17 +0200
commit12e77c03bcc41c143157d12d75d9b8a94457019d (patch)
tree5a53b7b03e025680af6a953ff4b1c885967d0d39 /gnu/packages/ghostscript.scm
parent397147aaad2e5d357479c0ff3ac3042432e320ae (diff)
downloadguix-12e77c03bcc41c143157d12d75d9b8a94457019d.tar
guix-12e77c03bcc41c143157d12d75d9b8a94457019d.tar.gz
gnu: libpaper: Update to 1.2.1.
* gnu/packages/ghostscript.scm (libpaper): Update to 1.2.1. [source]: Switch to currently maintained fork. [home-page]: Likewise. [arguments]: Remove #:phases. Add "--enable-relocatable" to #:configure-flags. [native-inputs]: Remove AUTOMAKE. Add HELP2MAN. [outputs]: Add "debug". * gnu/packages/tex.scm (texlive-bin)[arguments]: Add phase to patch test expected test result with libpaper 1.2. * gnu/packages/patches/libpaper-free-systempapername.patch, gnu/packages/patches/libpaper-free-xdg-config-home.patch, gnu/packages/patches/libpaper-invalid-paperspecs.patch: New files. * gnu/local.mk (dist_patch_DATA): Adjust accordingly.
Diffstat (limited to 'gnu/packages/ghostscript.scm')
-rw-r--r--gnu/packages/ghostscript.scm65
1 files changed, 28 insertions, 37 deletions
diff --git a/gnu/packages/ghostscript.scm b/gnu/packages/ghostscript.scm
index ca522e52ab..060fc43a1a 100644
--- a/gnu/packages/ghostscript.scm
+++ b/gnu/packages/ghostscript.scm
@@ -33,6 +33,7 @@
#:use-module (gnu packages cups)
#:use-module (gnu packages fontutils)
#:use-module (gnu packages image)
+ #:use-module (gnu packages man)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
@@ -74,45 +75,35 @@ Consortium standard (ICC), approved as ISO 15076-1.")
(define-public libpaper
(package
- (name "libpaper")
- (version "1.1.24")
- (source (origin
- (method url-fetch)
- (uri (string-append
- ;; Debian moved their libpaper-1.1.24 to archive.debian.net
- ;; but in the move the hash of their tarball changed.
- "http://pkgs.fedoraproject.org/repo/pkgs/libpaper/libpaper_"
- version ".tar.gz/5bc87d494ba470aba54f6d2d51471834/libpaper_"
- version ".tar.gz"))
- (sha256 (base32
- "0zhcx67afb6b5r936w5jmaydj3ks8zh83n9rm5sv3m3k8q8jib1q"))))
- (build-system gnu-build-system)
- (native-inputs
- (list automake)) ; For up to date 'config.guess' and 'config.sub'.
- (arguments
- `(#:configure-flags '("--disable-static")
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'fix-configure
- (lambda* (#:key inputs native-inputs #:allow-other-keys)
- ;; Replace outdated config.sub and config.guess:
- (for-each (lambda (file)
- (install-file
- (string-append (assoc-ref
- (or native-inputs inputs) "automake")
- "/share/automake-"
- ,(version-major+minor
- (package-version automake))
- "/" file) "."))
- '("config.sub" "config.guess"))
- #t)))))
- (synopsis "Library for handling paper sizes")
- (description
- "The paper library and accompanying files are intended to provide a simple
+ (name "libpaper")
+ (version "1.2.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/rrthomas/libpaper/releases"
+ "/download/v" version "/libpaper-"
+ version ".tar.gz"))
+ (patches (search-patches "libpaper-free-xdg-config-home.patch"
+ "libpaper-free-systempapername.patch"
+ "libpaper-invalid-paperspecs.patch"))
+ (sha256
+ (base32
+ "18m1yas7lihlyaxr0vpgy65bq9ri429wrm4sfxyhd5gj88gn16lr"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ (list help2man))
+ (arguments
+ '(#:configure-flags '("--disable-static"
+ ;; Tests require a relocatable build.
+ "--enable-relocatable")))
+ (outputs '("out" "debug"))
+ (home-page "https://github.com/rrthomas/libpaper")
+ (synopsis "Library for handling paper sizes")
+ (description
+ "The paper library and accompanying files are intended to provide a simple
way for applications to take actions based on a system- or user-specified
paper size.")
- (license license:gpl2)
- (home-page "https://packages.qa.debian.org/libp/libpaper.html")))
+ ;; The library is LGPL3+, everything else GPL3+.
+ (license (list license:lgpl3+ license:gpl3+))))
(define-public psutils
(package