aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2024-08-26 20:18:25 +0200
committerJulien Lepiller <julien@lepiller.eu>2024-09-14 18:49:39 +0200
commite48426b45421eb8199a0dadbcd0eef3f14511e27 (patch)
tree5bdf1cf6afae7256f74c29af34512ec86e126304 /gnu/packages/geo.scm
parent5fb9e04b6de24d5ff6478c9e4abe88a3a21fc43a (diff)
downloadguix-e48426b45421eb8199a0dadbcd0eef3f14511e27.tar
guix-e48426b45421eb8199a0dadbcd0eef3f14511e27.tar.gz
gnu: josm: Update to 19160.
* gnu/packages/geo.scm (josm): Update to 19160. [arguments]: Update phases accordingly. Update launcher following josm advice. Change-Id: Ic168cb04cf4248167b0724faecba8f2b2d238527
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm10
1 files changed, 8 insertions, 2 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index daaed4fa6a..5d120b3c98 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -2200,7 +2200,7 @@ to the OSM opening hours specification.")
(define-public josm
(package
(name "josm")
- (version "18907")
+ (version "19160")
(source (origin
(method svn-fetch)
(uri (svn-reference
@@ -2209,7 +2209,7 @@ to the OSM opening hours specification.")
(recursive? #f)))
(sha256
(base32
- "0vkczijw537f4y1b7hfxa45k3ww6nf2cf485b19dnbgh9ab6mnjl"))
+ "06m6rg9czs7mhkh0byd3c8n8y1gbzqqw2iy7qyn4084al4mdrw2z"))
(file-name (string-append name "-" version "-checkout"))
(modules '((guix build utils)))
(snippet
@@ -2280,6 +2280,9 @@ to the OSM opening hours specification.")
(lambda _
(system* "javac" "scripts/BuildProjectionDefinitions.java"
"-cp" "build/classes")
+ (mkdir-p "resources/data/projection")
+ (with-output-to-file "resources/data/projection/custom-epsg"
+ (lambda _ (display "")))
(mkdir-p "data/projection")
(with-output-to-file "data/projection/custom-epsg"
(lambda _ (display "")))
@@ -2342,6 +2345,9 @@ to the OSM opening hours specification.")
(not (string-contains jar "-javacc-"))))
(string-split (getenv "CLASSPATH") #\:))
":")
+ " --add-exports=java.base/sun.security.action=ALL-UNNAMED"
+ " --add-exports=java.desktop/com.sun.imageio.plugins.jpeg=ALL-UNNAMED"
+ " --add-exports=java.desktop/com.sun.imageio.spi=ALL-UNNAMED"
" org.openstreetmap.josm.gui.MainApplication"))))
(chmod (string-append bin "/josm") #o755))
#t)))))