aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-01-11 22:38:24 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-01-11 22:38:24 +0100
commitb7bf02a418e946b610ef68e8c5131f2350835956 (patch)
tree6d84387279b9870dc0b151bb9d3dce7f9d9de73d /gnu/packages/geo.scm
parent233c1be0a30846f6646b1f4edc6257037d0835fc (diff)
parent13efb24850bc40fab2448771c87c77c9a69fc231 (diff)
downloadguix-b7bf02a418e946b610ef68e8c5131f2350835956.tar
guix-b7bf02a418e946b610ef68e8c5131f2350835956.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 8e8e6dbe3b..32cdc2b53a 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -11,6 +11,7 @@
;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2019 Wiktor Żelazny <wzelazny@vurv.cz>
;;; Copyright © 2019 Hartmut Goebel <h.goebel@crazy-compilers.com>
+;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -252,12 +253,14 @@ and driving.")
(inputs
`(("libjpeg-turbo" ,libjpeg-turbo)
("libtiff" ,libtiff)
- ("proj" ,proj)
("zlib" ,zlib)))
+ (propagated-inputs
+ `(;; libgeotiff headers include proj headers, so ensure those are available.
+ ("proj" ,proj)))
(arguments
`(#:configure-flags
- (list (string-append "--with-zlib")
- (string-append "--with-jpeg")
+ (list "--disable-static"
+ "--with-zlib" "--with-jpeg"
(string-append "--with-libtiff=" (assoc-ref %build-inputs "libtiff")))))
(synopsis "Library for handling GeoTIFF (geographic enabled TIFF)")
(description "libgeotiff is a library on top of libtiff for reading and