aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2023-02-05 11:56:51 -0300
committerVinicius Monego <monego@posteo.net>2024-04-06 08:00:55 -0300
commit33d8c6904a58e46413b87cda063b91ddb48f8c57 (patch)
tree37aa25595e2b1b7cc222ce3e05b35631fffe8aea /gnu/packages/geo.scm
parentbfc614397b5f146056bda4b5a8e3a67bd1ca7b23 (diff)
downloadguix-33d8c6904a58e46413b87cda063b91ddb48f8c57.tar
guix-33d8c6904a58e46413b87cda063b91ddb48f8c57.tar.gz
gnu: Add libmseed.
* gnu/packages/geo.scm (libmseed): New variable. Change-Id: I6feb414110c30da408069b36b46a421467d2ccad
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 460f810d3e..4884a3803b 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -1911,6 +1911,34 @@ persisted.
")
(license license:expat)))
+(define-public libmseed
+ (package
+ (name "libmseed")
+ (version "3.1.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/EarthScope/libmseed")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "05sk2h19c7ja98s75b7hbn2cwnjc5l6dr59c23fgnaimmad2rfn7"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list #:make-flags #~(list (string-append "CC=" #$(cc-for-target))
+ (string-append "PREFIX=" #$output))
+ #:phases #~(modify-phases %standard-phases
+ (delete 'configure))))
+ (home-page "https://earthscope.github.io/libmseed/")
+ (synopsis "Library for the miniSEED data format")
+ (description "The miniSEED library provides a framework for manipulation
+of SEED data records, a format for commonly used for seismological time
+series and related data. The library includes the functionality to read
+and write data records, in addition to reconstructing time series
+from multiple records.")
+ (license license:asl2.0)))
+
(define-public python-rtree
(package
(name "python-rtree")