aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2024-03-02 12:22:34 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2024-03-02 12:22:34 +0100
commit25c14c893f05019d746321285acf55d1aa65b943 (patch)
tree9c0a728b3c723fd171668713e0755a79a2034098 /gnu/packages/geo.scm
parent71a3dca25cd25f63c8fc17498a9a729e545f1890 (diff)
parent4a0549be52f3f46fbce61342d8de30f7b83130c5 (diff)
downloadguix-25c14c893f05019d746321285acf55d1aa65b943.tar
guix-25c14c893f05019d746321285acf55d1aa65b943.tar.gz
Merge branch 'master' into gnome-team
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 64a6b4b918..32ccade4df 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -1676,7 +1676,7 @@ based on the Osmium library.")
(define-public osm2pgsql
(package
(name "osm2pgsql")
- (version "1.9.2")
+ (version "1.11.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -1685,7 +1685,7 @@ based on the Osmium library.")
(file-name (git-file-name name version))
(sha256
(base32
- "198qcgl42pb8lk1bn41ncp8hc9gcg9k2p0ny42vak019w5l6jcj7"))
+ "135vqahlcrhwa3b9hfgbiqkzbbsjd4i79fp41cd0rp4zarcpi47p"))
(modules '((guix build utils)))
(snippet
;; Remove bundled libraries.
@@ -1693,20 +1693,21 @@ based on the Osmium library.")
(build-system cmake-build-system)
(arguments
(list #:tests? #f ;tests fail because we need to setup a database
- #:configure-flags #~(list "-DUSE_PROJ_LIB=4" ;use API version 4
+ #:configure-flags #~(list "-DUSE_PROJ_LIB=6" ;use API version 6
"-DWITH_LUAJIT=ON"
"-DEXTERNAL_LIBOSMIUM=ON"
"-DEXTERNAL_PROTOZERO=ON"
"-DEXTERNAL_FMT=ON")))
(inputs (list boost
bzip2
+ cli11
expat
fmt-8
libosmium
luajit
nlohmann-json
postgresql
- proj-7
+ proj
protozero
zlib))
(native-inputs (list pandoc python python-argparse-manpage))