aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-02-08 19:19:44 +0100
committerRicardo Wurmus <rekado@elephly.net>2024-02-08 19:20:25 +0100
commit24e87f64cfaf6fb5c3ac1fda9ac67c277c610c5e (patch)
tree199ad5a93465f578a08b411c2a6b86cfc7a2f6c7 /gnu/packages/geo.scm
parenta903558577d249354aa74bbd6aab897235a7602b (diff)
downloadguix-24e87f64cfaf6fb5c3ac1fda9ac67c277c610c5e.tar
guix-24e87f64cfaf6fb5c3ac1fda9ac67c277c610c5e.tar.gz
gnu: Add python-geoip2fast.
* gnu/packages/geo.scm (python-geoip2fast): New variable. Change-Id: Ia1ca57ac281c487db65ad3474940e8326082b7a1
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 7ceb3cd54a..aeb3a9fbd2 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -3106,6 +3106,30 @@ path loss.")
"This is a python implementation of the geodesic routines in GeographicLib.")
(license license:expat)))
+(define-public python-geoip2fast
+ (package
+ (name "python-geoip2fast")
+ (version "1.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "geoip2fast" version))
+ (sha256
+ (base32 "1cmdjlwjd4pg3qvsb8d4vghqj1im58npxb6dmrd5q90wjga4rfvm"))))
+ (build-system pyproject-build-system)
+ ;; The tests are speed tests or development tests to compare results with
+ ;; a different library.
+ (arguments (list #:tests? #false))
+ (home-page "https://github.com/rabuchaim/geoip2fast")
+ (synopsis
+ "Fast GeoIP2 country/city/asn lookup library")
+ (description
+ "@code{GeoIP2Fast} is a fast @code{GeoIP2} country/city/asn lookup
+library that supports IPv4 and IPv6. A search takes less than 0.00003
+seconds. It has its own data file updated twice a week with
+Maxmind-Geolite2-CSV, supports IPv4/IPv6 and is pure Python.")
+ (license license:expat)))
+
(define-public python-geopy
(package
(name "python-geopy")