aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
authorRomain GARBAGE <romain.garbage@inria.fr>2024-03-11 12:07:15 +0100
committerLudovic Courtès <ludo@gnu.org>2024-04-04 16:19:20 +0200
commit1c827ef19e853b694df85a60f8c7b0f4ca5a1fc6 (patch)
treebe9bb6c22a22a071b0f15a2261fac3ef873fc3f7 /gnu/packages/geo.scm
parent8eeef890f3e6b0c9e9bada4cee5968aa56d5c146 (diff)
downloadguix-1c827ef19e853b694df85a60f8c7b0f4ca5a1fc6.tar
guix-1c827ef19e853b694df85a60f8c7b0f4ca5a1fc6.tar.gz
gnu: grass: Remove dependency on lapack.
* gnu/packages/geo.scm (grass): Remove dependency on lapack. Add 'fix-lapack build phase. Change-Id: I758a9b2434f0ad9f8b85a5c5cde6d0a80e6defb2 Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 506180461d..460f810d3e 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -2609,7 +2609,6 @@ orienteering sport.")
("gdal" ,gdal)
("geos" ,geos)
("glu" ,glu)
- ("lapack" ,lapack)
("libpng" ,libpng)
("libtiff" ,libtiff)
("mesa" ,mesa)
@@ -2643,6 +2642,11 @@ orienteering sport.")
(guix build python-build-system))
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'fix-lapack
+ (lambda _
+ (substitute* "./configure"
+ (("-lblas") "-lopenblas")
+ (("-llapack") "-lopenblas"))))
(replace 'configure
(lambda* (#:key inputs outputs #:allow-other-keys)
(let ((shell (search-input-file inputs "/bin/bash")))