aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/gdb.scm
diff options
context:
space:
mode:
authorJanneke Nieuwenhuizen <janneke@gnu.org>2023-06-17 13:51:05 +0200
committerJanneke Nieuwenhuizen <janneke@gnu.org>2023-06-17 14:38:32 +0200
commitff690faf66d8f37ee6b679fcb7cf37e369624ee3 (patch)
tree3d6ab4ebded5a48f349ca5701643699e178481b4 /gnu/packages/gdb.scm
parent52f2980fa3feaf6e59b9e5144391faf8feb52a87 (diff)
downloadguix-ff690faf66d8f37ee6b679fcb7cf37e369624ee3.tar
guix-ff690faf66d8f37ee6b679fcb7cf37e369624ee3.tar.gz
gnu: Use target-hurd?, system-hurd? instead of hurd-target?, hurd-system?.
* gnu/packages/hurd.scm (hurd-target?): Remove. (hurd-system?): Move to... * guix/utils.scm (system-hurd?): ...here. * gnu/packages/*: Update all users, removing (gnu packages hurd) include where now unused.
Diffstat (limited to 'gnu/packages/gdb.scm')
-rw-r--r--gnu/packages/gdb.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/gdb.scm b/gnu/packages/gdb.scm
index a8d8a86ea8..34d081dc9e 100644
--- a/gnu/packages/gdb.scm
+++ b/gnu/packages/gdb.scm
@@ -114,14 +114,14 @@
("libxml2" ,libxml2)
;; The Hurd needs -lshouldbeinlibc.
- ,@(if (hurd-target?)
+ ,@(if (target-hurd?)
`(("hurd" ,hurd))
'())))
(native-inputs
`(("texinfo" ,texinfo)
("dejagnu" ,dejagnu)
("pkg-config" ,pkg-config)
- ,@(if (hurd-target?)
+ ,@(if (target-hurd?)
;; When cross-compiling from x86_64-linux, make sure to use a
;; 32-bit MiG because we assume target i586-pc-gnu.
`(("mig" ,(if (%current-target-system)