aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/gd.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-03-13 21:40:56 -0400
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:44:59 +0200
commitb2c8082977dcc8361d234a3b187286b0d1b10e80 (patch)
tree695d34b725e4816f671fe72acc0d764bc79fbd1e /gnu/packages/gd.scm
parentd803f8ae41e59f8084ebb4a300d2a42a631c8514 (diff)
downloadguix-b2c8082977dcc8361d234a3b187286b0d1b10e80.tar
guix-b2c8082977dcc8361d234a3b187286b0d1b10e80.tar.gz
gnu: perl-gd: Update to 2.78.
* gnu/packages/gd.scm (perl-gd): Update to 2.78. [native-inputs]: Add perl-test-nowarnings. Change-Id: I13e961bc6f6c77484dc698619338e083bbb5b7aa
Diffstat (limited to 'gnu/packages/gd.scm')
-rw-r--r--gnu/packages/gd.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/gd.scm b/gnu/packages/gd.scm
index 21ad1579ec..2c5ba59915 100644
--- a/gnu/packages/gd.scm
+++ b/gnu/packages/gd.scm
@@ -31,6 +31,7 @@
#:use-module (guix download)
#:use-module (gnu packages)
#:use-module (gnu packages perl)
+ #:use-module (gnu packages perl-check)
#:use-module (gnu packages image)
#:use-module (gnu packages imagemagick)
#:use-module (gnu packages fontutils)
@@ -101,14 +102,14 @@ most common applications of GD involve website development.")
(define-public perl-gd
(package
(name "perl-gd")
- (version "2.73")
+ (version "2.78")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://cpan/authors/id/R/RU/RURBAN/"
"GD-" version ".tar.gz"))
(sha256
- (base32 "0arjpa8id6k5yjxfq0j2hsinhhjzjch5lwk6gscf48l54drrw729"))))
+ (base32 "1r3fpr8jhpwi48i66rickiphyj442hypsqnk4df4yjs2ym5hacb8"))))
(build-system perl-build-system)
(inputs
(list fontconfig
@@ -118,7 +119,8 @@ most common applications of GD involve website development.")
libjpeg-turbo
zlib))
(native-inputs
- (list perl-extutils-pkgconfig))
+ (list perl-extutils-pkgconfig
+ perl-test-nowarnings))
(arguments
(list #:make-maker-flags
#~(list (string-append "--lib_jpeg_path="