aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/gd.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2023-02-24 14:53:56 +0100
committerLudovic Courtès <ludo@gnu.org>2023-02-25 00:00:32 +0100
commit5c4240442cd39fd5d279e080184f0ee2fb1c8af4 (patch)
tree219f46edd406e9f8fda5cf8c82fc8535f8cfbbe8 /gnu/packages/gd.scm
parent279b0122b63502f1d5ea027025dcc4dd4180e478 (diff)
downloadguix-5c4240442cd39fd5d279e080184f0ee2fb1c8af4.tar
guix-5c4240442cd39fd5d279e080184f0ee2fb1c8af4.tar.gz
gnu: perl-gd: Use gexps.
This helps cross-compilation: in that case, '%build-inputs' was unbound. * gnu/packages/gd.scm (perl-gd)[arguments]: Rewrite using gexps.
Diffstat (limited to 'gnu/packages/gd.scm')
-rw-r--r--gnu/packages/gd.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/gd.scm b/gnu/packages/gd.scm
index 02e05c6072..90023ddc84 100644
--- a/gnu/packages/gd.scm
+++ b/gnu/packages/gd.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013, 2016 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2016, 2023 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015, 2016 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2016, 2017 Leo Famulari <leo@famulari.name>
@@ -23,6 +23,7 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages gd)
+ #:use-module (guix gexp)
#:use-module (guix packages)
#:use-module (guix build-system gnu)
#:use-module (guix build-system perl)
@@ -117,9 +118,9 @@ most common applications of GD involve website development.")
(native-inputs
(list perl-extutils-pkgconfig))
(arguments
- `(#:make-maker-flags
- (list (string-append "--lib_jpeg_path="
- (assoc-ref %build-inputs "libjpeg")))))
+ (list #:make-maker-flags
+ #~(list (string-append "--lib_jpeg_path="
+ #$(this-package-input "libjpeg-turbo")))))
(home-page "https://metacpan.org/release/GD")
(synopsis "Perl interface to the GD graphics library")
(description "GD.pm is an autoloadable interface module for libgd, a