aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/gcc.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-10-18 01:00:40 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-10-18 08:41:48 +0300
commitb41ff1a00d551e211c31a9530b7c9a034a6d33c8 (patch)
treea1bc618ff2ca40ef4bad7372da90b9c6638f8511 /gnu/packages/gcc.scm
parent96f8945425c9b43cc083733d2331bc305650c902 (diff)
downloadguix-b41ff1a00d551e211c31a9530b7c9a034a6d33c8.tar
guix-b41ff1a00d551e211c31a9530b7c9a034a6d33c8.tar.gz
gnu: gcc-2.95: Add initial work toward building for arm.
* gnu/packages/gcc.scm (gcc-2.95)[source]: Adjust source to use newer macros from more recent versions of GCC.
Diffstat (limited to 'gnu/packages/gcc.scm')
-rw-r--r--gnu/packages/gcc.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index ea9b9e57f4..bb154cac62 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -745,7 +745,10 @@ It also includes runtime support libraries for these languages.")
(delete-file-recursively "texinfo")
(substitute* "configure"
(("host_tools=(.*)texinfo" _ before)
- (string-append "host_tools=" before)))))))
+ (string-append "host_tools=" before)))
+ ;; Fix building on arm* with gcc-4+
+ (substitute* "gcc/config/arm/arm.c"
+ (("arm_prog_mode") "arm_prgmode"))))))
(supported-systems (fold delete %supported-systems
'("powerpc64le-linux" "riscv64-linux")))
(native-inputs (list texinfo dejagnu))