aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/gcc.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2023-04-13 11:46:47 +0200
committerAndreas Enge <andreas@enge.fr>2023-04-13 18:53:42 +0200
commit9900f9e9b86550e7d336b04ad46fba088e28cbd6 (patch)
tree91bd16bd70e66d2ec42c0049fbca3e45137a6803 /gnu/packages/gcc.scm
parenta957171bc41e98e29674f99cf3dd2940ff45a0d3 (diff)
downloadguix-9900f9e9b86550e7d336b04ad46fba088e28cbd6.tar
guix-9900f9e9b86550e7d336b04ad46fba088e28cbd6.tar.gz
gnu: gcc-11: Fix build on powerpc64le.
* gnu/packages/patches/gcc-11-libstdc++-powerpc.patch: New file. * gnu/local.mk (dist_patch_DATA): Register patch. * gnu/packages/gcc.scm (make-libstdc++): Apply patch for gcc versions >= 11 and < 12 on ppc64le. Co-authored-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/gcc.scm')
-rw-r--r--gnu/packages/gcc.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index a511cdbc45..ae324219d3 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2012-2023 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014, 2015, 2018 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2014, 2015, 2016, 2017, 2019, 2021 Ricardo Wurmus <rekado@elephly.net>
-;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2015, 2023 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2015-2018, 2020-2023 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Carlos Sánchez de La Lama <csanchezdll@gmail.com>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
@@ -889,6 +889,15 @@ using compilers other than GCC."
":")
"\nAM_CXXFLAGS = ")))))))
'())
+ ,@(let ((version (package-version gcc)))
+ (if (and (target-ppc64le?)
+ (version>=? version "11")
+ (not (version>=? version "12")))
+ `((add-after 'unpack 'patch-powerpc
+ (lambda _
+ (invoke "patch" "--force" "-p1" "-i"
+ (search-patch "gcc-11-libstdc++-powerpc.patch")))))
+ '()))
;; Force rs6000 (i.e., powerpc) libdir to be /lib and not /lib64.
(add-before 'chdir 'fix-rs6000-libdir
(lambda _