aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/gcc.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-03-27 15:47:48 +0100
committerLudovic Courtès <ludo@gnu.org>2013-03-27 15:47:48 +0100
commit5c126b645eab6cdfee3d72cb4a0980519994442f (patch)
tree74b971cac4e780e72dd774a4872cd61aecc60573 /gnu/packages/gcc.scm
parent832abc76874e8041096bdcd23b7a3a68d6439180 (diff)
downloadguix-5c126b645eab6cdfee3d72cb4a0980519994442f.tar
guix-5c126b645eab6cdfee3d72cb4a0980519994442f.tar.gz
gnu: Add libelf.
* gnu/packages/gcc.scm (libelf): New variable.
Diffstat (limited to 'gnu/packages/gcc.scm')
-rw-r--r--gnu/packages/gcc.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index 76146ad8fc..116c1859a9 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -211,3 +211,31 @@ matters. While the user has full control on generated code quality,
CLooG is designed to avoid control overhead and to produce a very
effective code.")
(license gpl2+)))
+
+(define-public libelf
+ (package
+ (name "libelf")
+ (version "0.8.13")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://www.mr511.de/software/libelf-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0vf7s9dwk2xkmhb79aigqm0x0yfbw1j0b9ksm51207qwr179n6jr"))))
+ (build-system gnu-build-system)
+ (arguments '(#:phases (alist-replace
+ 'configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; This old `configure' script doesn't support
+ ;; variables passed as arguments.
+ (let ((out (assoc-ref outputs "out")))
+ (setenv "CONFIG_SHELL" (which "bash"))
+ (zero?
+ (system* "./configure"
+ (string-append "--prefix=" out)))))
+ %standard-phases)))
+ (home-page "http://www.mr511.de/software/english.html")
+ (synopsis "An ELF object file access library")
+ (description "libelf is a C library to access ELF object files.")
+ (license lgpl2.0+)))